Cant hear Midi when project is stopped - but can in play

This happens randomly, i can’t figure out what the issue is. - Using a Saffire Pro 24 with buffer rate @ 1536.

I use alot of Kontakt and various 3rd party libraries, all triggered by my Casio Privia. Sometimes my Kontakt libs won’t play when the transport bar, thus project is stopped. But as soon as i press play the sound comes through again. So when this happens i end up having to solo the kontakt track and press play just to preview the sound.

Sometimes if I turn on the Constrain delay compensation button it starts to work when the project is stopped (but normally when its working as it should i don’t have to do this) . On a few ocassions turning the Constrain Delay button on and then off again resolves the issue, but not all the time

Midi reset doesn’t help.

Anyone know what the issue might be? Anything in preferences that might be causing the problems?

Many Thanks.

Track monitor enabled?


It will currently only let me hear the Midi (whilst project is stopped) if i turn on the Constrain Delay Compensation.

Enable monitor to hear live play.

Still no sound when its stopped with Monitor ON… Oddly when i press play i can only hear the midi when Constrain Delay is turned OFF, and i can only hear Midi when the projects stopped if Constrain Delay is ON. :frowning:

Set midi inputs in the Inspector? Then the monitor switch.
Simultaneous reply. Constrain delay should have nothing to do with it at all.

Sorry what do you mean set midi inputs? Reassign them?

Something’s FUBAR. Same in a new blank project?. If yes and starting in Safe Mode solves it, trash Prefs. If not, re-install.

Thanks for helping NWP. Just opened another project and its back to normal. This problem is really random, sometimes it will happen other times it won’t.

Been happening since Cubase 7.0 and throughout every update since. Won’t do a fresh install now as im upgrading to 7.5 in two days. So will see what happens then.

Steinberg - Do you have any ideas?

Wasn’t sure if you had them assigned. Just the first idea that seemed the obvious type of mistake to make given the description.
Top of Inspector under main Track header? Box marked “no connections” with dropdowns for All Midi Inputs or specific to your soundcard midi inputs.

Maybe some setting for the Focusright Control Panel?