Can't hide bar number at rehearsal mark

Setup/Layout Options/Bar Numbers-- relevant box is unchecked (see attached) in both Galley and Page View. My letter A’s bar number shows, for B it is hidden. That doesn’t seem right to me.

In general you shouldn’t expect this option to affect bar numbers shown at the very start of the system, unless you also set rehearsal marks to be aligned with the very start of the system.