Can't Install 5.1

When I run the Steinberg Download Assistant, I get the following message, even though I am clearly connected to the Internet. Advice?


Update the SDA Steinberg Download Assistant. There are several other threads reporting the same. The older version doesn’t connect to their servers anymore.

To be precise: uninstall SDA first, then download and install it from here:

1 Like

Thank you. I will follow your helpful directions.

Note that I was able to download and install 5.1 without the Assistant; however, after installing, when I opened Dorico, I got a message that Iconica–whatever that is–was missing and that it is a critical component. I don’t see that in the install folder I downloaded. Dorico seems to be working anyway.

Hi Konrad :slight_smile: If you open SDA (now working) and go to Dorico, you’ll find any component, including Iconica. You can install what you are missing, or, better, install all again!


When I follow @Alberto_Maria’s link, I land on a page that look like this:

  1. Clicking Steinberg Download Assistant 1.35.0, just takes me back to the same page.
  2. When I go to the Downloads page, Steinberg Download Assistant is not one of the choices in the drop-down.

I am going in circles and still getting the message that Iconica is missing.

What do I need to do?

OK, I think that clicking that link was actually downoading the installer but was not giving me any message that was happening. I ran the installer for the updated download assistant.

When I run Download Assistant, I don’t see anything named “Iconica” to download. So, I guess I am back where I started.

UPDATE: Never mind. You are supposed to know that, even though there is a list of products, you are supposed to know to click the Dorico 5 icon to open another list of products and that is where Iconica is. Either the process is unclear, I am stupid, or some of each.

If I follow my link I get this:

where everything works perfectly!

Anyway you’ll find Iconica and all the rest inside the Dorico space of SDA…

1 Like

Thank you. This is resolved now.

1 Like

:+1: :bangbang:
(check the thread as solved!)