Can't Install Cubase 6.5.0

Hello,

I’m using High Sierra 10.13.2 and I cannot install Cubase 6.5 because it’s telling me that I need OS Version 10.5.0 or higher. That makes no sense.

Is my purchase of Cubase 6 completely useless now? Do I have to churn out $500+ for Cubase 9.5 just so that I can bounce down some soloed bass tracks for my band’s new touring bassist?

Thanks!

Use this:
https://www.steinberg.net/en/support/content_und_zubehoer/content_and_accessories_sait.html

Upgrading sometime in the future is still a good idea since 6.5 is buggy on modern Mac OS X (thanks to Apple) and recent versions of Cubase have many big performance and workflow improvements. The upgrade price for you is actually $299.

Thank you, thank you, works beautifully. You’ve saved me.