Can't log in to My Steinberg to check upgrades....

I’m stuck in a quandary and don’t know where else to post. We have a number of Nuendo systems that we’re considering upgrading to v7 and I’m unable to log in to My Steinberg. I’ve tried repeatedly over the past several days to log into My Steinberg using the same username and password I’ve always used to get in and I receive a message that my “…email and/or password are invalid…”. I’ve tried the “forgot password” process three times over a few days and the email does not come in.

To contact support the site tells me I must log in to My Steinberg. Not sure what to do with that.

Obviously -
-Used the same username and password I’ve used numerous times before, we keep accurate password records.
-Tried various case combinations in the username
-Repeatedly checked junk mail folders for password reset email.
-Accurate email address in the Forgot Password process.

Is anyone able to help? This is a circular situation that we can’t escape from without assistance.

Use firefox.
I had lots of trouble getting in and changing password and/or account details with chrome.

Hello bifop,
Thanks for the response but I’ve already tried Safari, Firefox, and two OS versions of iOS Safari.

Anyone know what happened to my account?


Maybe ask a moderator…

Same thing happened to me. Contacted US support but they couldn’t solve the problem. They had me contact support in Germany. Waiting to hear back from them. I’ll keep you posted when I hear something.

Same problem here. I have had the same username and password since 2007. My primary email address has changed, however. That was my problem. My Steinberg didn’t recognize my valid user name, which has never changed. It wanted an email address, would not accept my username. My current email address didn’t work either. Then I looked through my old records and found the email address on record from 2007 (luckily I still own it!)
Voila! I was in. I’m not sure if this will help you, but I hope so.

I heard back from support in Germany. They were able to solve the problem and get me logged in. I suggest you contact US support. They can get you in touch the German support since you can’t log in to file a report. Hope you get the problem solved quickly.

Hello for an update because I don’t have anywhere else to complain -

It’s been around 11 days and I still can’t log in. Jeff from US Support got me in touch with German support who have access to the database. Uwe sent me a password but I still can’t get in. The login page lets me know that my email address and username exists in the database but I’m not able to log in.
I’ve sent another message to Germany. I shouldn’t have to waste this much time on something that I’m forced to do.

PM sent

Steve, thanks for the PM, Uwe did “something” else and I was then able to get in. Rather silly and quite a waste of my time. Fortunately the support folks were helpful, it just took too long.