Can't make my Percussion part go on a 5-staff line

Hoping someone can point out the error of my ways here.
I’ve created a percussion part and have indicated in the player layout that I wanted it on a 5-staff line. It still shows up on a 7-staff line. What am I doing wrong?
Thanks in advance!

Open Layout Options–Players–Percussion. That’s where you select the percussion format for that particular layout.

Weird! I looked and it was checked as 5-staff. I then selected grid for shits and giggles and went back to 5-staff and it gave me the option to click apply. I did and it’s all good.
Thank you as always!