Can't open m4a anymore

Apple’s m4a files, lossless and lossy, can’t be opened anymore with WaveLab 11. Former versions don’t have that problem. WaveLab now reports that the format is unknown.
Frank

11.1 will open an m4a for me, but it just becomes white/digital noise…

glad i finished a project yesterday where the client sent me old live recordings in m4a format!

hope this gets fixed STAT.

m4a is not a file format but a file container. What’s in your file? Whar kind of AAC?
Something changed indeed: from WaveLab 11.1, the lossless AAC encoding/decoding is not part of WaveLab anymore, because it is no longer supported by Fraunhoffer, on which WaveLab relies for AAC. I recommend using FLAC and even better, WavPack, if you need lossless encoding.

Mostly Apple lossless. I ripped nearly all of my CDs (nearly 4000), LP transfers and broadcast recordings in that format until about 2019. It’s sad that a software for Mac doesn’t support the main Mac format anymore.

Do we know why the Fraunhofer codec no longer supports lossless AAC (a.k.a. ALAC)?

These files should have the extension “.alac”.
WaveLab 11.1 can open them as past WaveLab could open them. Nothing was changed here.

Not exactly. But this could be a patent issue. And also, very little usage of this format.

Was this ever a Fraunhofer codec? I always thought that - at least the lossless version - was an Apple exclusive format.
In the meantime I found out that WaveLab 11.1 can open the lossy .m4a files but no more
Apple lossless files. Here I always get the message that the format is wether unknown or that there is no decoder for it on my MAC (!). It’s the prime format on a Mac and Apple Music still doesn’t work with FLAC files. In former times they could be opened and edited with WaveLab, too, and it would be fine if that would work in the future, also.
I tried that on WaveLab 10 on an old Mid-2010 MacPro. There is no problem to open Apple lossless files but the result is an obviously empty file with no music and a flat zero curve. But it’s there when I play the same file in Apple Music, iTunes, JRiver MediaCenter or the finder.
Neither Fission nor Isotope RX9 has any problem to open and edit Apple lossless correctly.
Frank

There are two different things. Apple lossless should have the file extension .alac and can be opened with both present and past WaveLab versions. This is not a Fraunhofer codec.

But the AAC lossless format that was present in WaveLab <= 11 (encoding and decoding) is a Fraunhofer codec.
From WaveLab 11.1 we are not allowed to use that codec.

Please send me such a file so that I can check it.

Only a small snippet from one file.
Chanson des baleines de parapluie.zip (579.4 KB)

Thanks for your file. Indeed, this is an apple lossless file.
WaveLab 11.1.10 will be able to open it directly, but in the meantime, if you want to open it now, then rename the file extension as .alac

1 Like