Can't playback Audio CDs anymore on a certain Drive

I have quite a curious problem:

I am using an external USB CD/DVD drive since years (ICY Box with LG DVD-R) - it seems to work nicely - I burnt Master CDs yesterday… which were 100% fine… but I was not able to playback the Master CD (or any other Audio CD) anymore… which made me look somewhat funny in front of my clients :laughing:

The first song starts, no audio is there, after that the whole thing hangs and I am not even able to eject the CD - or close the Media Player. I have to switch the drive off and on to reset the process. Same when using VLC - and even when I open the CD with the Wavelab CD Import menue.

I just tried CDs at the internal DVD drive (Computer is in another room) - it works - as well as I connected another external USB DVD-R - and it works perfect here as well.

Is this drive defective? Or are there any other reasons? Burning CDs and reading DVDs is still fine! Master CDs are having perfect C1/C2 error rates…

Sounds like a Hardware Problem.
You might have a look though and see if there is a firmware update or driver update for the unit first.

They can and do go bad.

Especially in a studio environment where lots ‘o burning is goin’ on.
In the past have gone thru one or two.

However I have not burned a single CD for a client for this entire year 2014 so far.

Mp3s/uploads and flash drives seem to now the main conveyance methods.

Guess I can now safely sell my DAT machine. :slight_smile: :slight_smile:

Good luck!

Hey thanks :slight_smile:

Hehe yes it is crazy with those “old” formats… Having a DAT and even a Tape machine here… but from time to time someone with an “old demo” comes in…

Regarding the DVD - well, I was in a hurry so I just started to use another external DVD-R which worked nicely… Because a new LG DVD-R costs 12 EUR (!) only I just ordered one because I needed HDs anyway… I will check out if this will fix it, if not then it might be that external blue-illuminated case from Icy Box…

Funny thing is that I burnt a Master CD as well as 5 copys 10 minutes before - and all of them are fine (checked with Plextools Pro on an other system)… It seems that only the “Audio CD playback” is brocken… I can still use the drive for data stuff as well as for burning…

Regarding the “it’s 2014” thing… yes - I can feel and see a trend into the “I will upload a DDP file to the duplication factory” direction - but Bands which spent weeks and 1000s of Bucks into their album production still loves to hold a cool Master CD in their hands at the end… in the same time I often have bands were the members prefer to listen to the rough mixes on a regular audio cd (maybe on their way home in the car)… So I would say I am still burning CDs - but in addition I usually provide a digital-online version…

I have a drive like that, I think it’s an HP lightscribe - that’ll be the second one of those that went south quickly - never again.
I’m sure the new drive will solve your problem. :wink:
(I still have an “antique” Pentium PC running Windows 95 or 98, with a tape drive as well as 5-1/4 floppy in the studio. I keep it primarily though for a 6502 microprocessor emulation software, I still need for programming an even older synth. :laughing: )