can't select the audio device/can't record

I am haveing problem with recording an audio. I can’t select the audio device for the input(I have attached a pic). I would like to record sound through microphone which is plugged in to the external soundcard(creative soundblaster 5.1). In windows I can record the sounds, but I can’t manage to do it in Cubase.
Also I have a turntable, which is connected to the PC via USB, but I can’t connect it to Cubase as well(in Windows it’s working, recording the sound, but not in Cubase).
I followed all the instructions I have seen regarding this issue, but none of them helped.
issue.jpg

1st post. WELCOME!

Looks like you have not assigned the ASIO driver for your Creative SB 5.1 in the Cubase>Devices>Device Setup>VST Audio System menu. Once you do that, the SB 5.1 inputs and outputs will be available in the VST Connections menu.

Regards :sunglasses:

Thank you for the reply.
In the VST audio systyems I have chosen the soundcard I am using(creative soundblaster, you can see it on the picture as well). Outputs are working fine, I can pick whether I want to use the external card or not. And it is ticked in as well. When it comes to inputs, I cant modify them.
issue2.jpg

So in the first pic of vst connections/inputs where you have “not connected” ticked you need Creative Soundblaster ticked…is that not possible??

i think it is not possible, but as you see it is…and it was the same with cubase elements 8
-inputs , not possible to modify
-outputs, working ok, I can set anything

Well if you are unable to select this I can only think it is an issue with the soundcard asio driver.

You could try running it with ASIO4all driver instead for recording.

So, with ASIO4all I can modify the audio device, but then the speakers are not working(they are plugged into an external sound card). If I would plug the mic and the speakers into the PC it would work, but then why did I buy a sound card for. There has to be a solution for this.

Devices->device setup->VST Audio System->dropdown menu: Audio interface

when I have this setup the issue occurs that I am not able to record in Cubase. When I have the ASIO4all then I have to replug my cables.
I would like to record via my external sound card(in windows everything is ok)
issue3.jpg

you should not need to replug anything…You probably just need to configure ASIO4all and VST connections properly.

When I have the ASIO4all as the VST audio system, I can only select some HD speakers both for inputs and ouputs as well. Those are not my speakers…and def. it’s not a mic.

Only thing I can think of… are your in- and outputs visible?
In Device Setup you selected your ASIO, then click on “Creative Sound Blaster ASIO” directly under “VST Audio System”.

I’ve added a screen how mine looks, yours should show your available ins and outs and they should be “visible”, ofcourse.
Asio Setup.jpg

Open the ASIO4all panel from system tray while it is running inside Cubase.
In the list of devices make sure the little on button is lit up for all of the devices you want to use…just click to turn on.