Can't Solo on Avid Artist Mix

Hi,
I wonder if anyone else is having this issue.
I’m running Cubase 9.5 (latest update) on macOS High Sierra with the latest Eucon version.
For some reason clicking the Solo buttons does not solo the tracks. Mute (or ON in the artist mix) works just fine.
I can solo using my mouse or a keyboard shortcut but I don’t get the visual feedback from the controller.

Anybody else using Artist mix is having this problem?

thanks :slight_smile:

The Solo button just started activating the Listen mode for me. Not sure how to change it back…
Any help would be appropriated.

Did you ever figure this out? Just got an artist mix and by default the solo button turns on listen mode, which IMO is useless as faders do not work in listen mode!

SOLUTION: For anyone who finds this, I figured it out. Seems to be a bug somewhere but here is a work around. In the EuControl App, go to settings -> General. You then have change the option for “Open Windows on Workstation When Editing” To something other than off. Dont know why, but this fixes the solo issue. Totally seems like a bug, but at least its working now.

Hi!
Maybe you are in the wrong Solo Mode. Just open EuControl panel and go to “General”. Then select “Solo in Place” in the “Solo Mode” field.
Hope that helps.

cheers

Hi, none of the above recommendations worked for me. Solo on the now S1 still activate the Listen mode in Cubase. Has anyone found another solution?
-j

@chednb is correct! We have 3 S1’s and a Protools Dock. Pressing (Solo) across all control surfaces activated (Listen) in Nuendo 10. In Eucon Control Settings, under the General Tab, tick “Solo in Place” a restart may be necessary. If it works in Nuendo, I find it hard to believe it wouldn’t work for little brother Cubase.