Cant Time stretch audio,what am i doing wrong?

I usually never ask these sort of question but for the life of me I cant figure out what I am doing wrong.I want to slow down a track by a few bpm to hear how it sounds.Its mostly audio tracks so it will need to be time stretched.This video at 14.20 is an example https://www.youtube.com/watch?v=QFeRu5J38Cs I have done this before but cannot seem to remember.Ive toggled between linear and musical on the tracks,the tempo track is on,ive used elastique pro etc.When he adjusts the tempo the audio slows down.Its not happening for me.What the hell am i forgetting?Cheers

Maybe setting the files to musical mode ?

With the tempotrack on, you can not change tempo in the transport bar.

Yes I have tried both musical and linear.Maybe its because the tempo track is on.Weird because I have done it before a few times.Just cant remember what I did.

Yes I have tried both musical and linear

Wrong musical mode!

Open the pool, select all files and tick the box.

Yes I have tried both musical and linear

That´s not musical mode - that´s track timebase.

[Pedant alert]: There is Musical Mode, as Grim has mentioned. This lets you stretch the audio as you’d like, sounds like the tool you are looking for.

: There is Musical Timebase, and its counterpart Linear Timebase. These have nothing to do with stretching, or to do with Musical Mode. They are used when the tempo track is being changed.
a) When you change the tempo track, do you want the events on a certain track to “stay with the beat”? For example, do you want the vocal to still come in at the beginning of the 10th measure after you change the tempo track? Then, before changing the tempo track, put the vocal track into Musical Timebase.
b) And there is Linear Timebase: Alternatively, when you change the tempo track, do you want that “gunshot” sound to stay at 5 min and 47 seconds into the film you are scoring (as opposed to staying on the 3rd beat of the 94th measure)? Then, before changing the tempo track, but the “gunshot sound” track into Linear Timebase.

Hope that helps a bit!

[/pedant alert out!]

Yup i hadnt got it set to musical mode.I was selecting musical and linear time base instead.Silly me.Cheers guys