Can't uninstall Yamaha Steinberg USB Driver

I’m trying to install the new Yamaha Steinberg USB Driver 1.10.0, so I follow the instructions and try to uninstall the old driver.

That is not possible:
I then tried to install the new driver anyway, but got the same message.

Any hints, please?

I’m running Win 10, 1709.

Have you restarted the computer?

Yes, several times during the fault-finding proces. And I am the admin of my pc, so I allways run as admin.

I actually had this problem too when I installed 1.09, but I don’t know (or remember), how it got solved. I just remember, that it was hard work getting it solved.

The only other thing I can suggest is to unplug the hardware, restart, and try. Other than that, it could be a registry problem or missing uninstaller information and I don’t know how to fix those.

Installed fine here without uninstalling the previous driver.

I do however extract the download before running the installer. I’ve had problems with this in the past when I ran the installer straight away without extracting it first.

Hi, I had the same problem, could not uninstall even with uninstaller on super mode, no files were on hard disk after this but new driver still recognized smth and could not be installed. I managed to solve it with system restore in control panel but if it shows you a message error then you have to rename folder windows Apps (you have how to online if you see the message)…but maybe you can uninstall it by clicking the uninstall file I have seen in users,comp name, app data, roaming, yamaha uninstall or smth like that (it could be a hidden folder so make it show), i couldnt cause i deleted it first…Same problem but I got a message sayin driver already installed instead of this…

In C:\Users\Username\AppData\Roaming\YAMAHA there’s only the config file for my THR-editor. No Yamaha Steinberg USB Driver.
The THR actually uses the same YSUSB driver, but I’ve obviously disconnected the THR during my attempts to driver installation.

These files are listed in C:\Program Files (x86)\Yamaha\Yamaha Steinberg USB Driver:
I’ve tried to delete these files manually, but I still got the above mentioned error message. So I put the files back in place, in order to still have a working driver.

Also I found when showing hidden files in c, program data, yamaha uninstaller and then this file but i didnt try it dont know if it really uninstalls,maybe it helps you,if not,system restore and make sure you create system restore points when everything works so you can go back to this time…

Tried restore - didn’t work.

But this is interesting:
I tried to install the 1.9.11 driver again. The setup asked to remove the already installed driver (also 1.9.11). I clicked “OK”, and the proces appearently worked - uninstalling 1.9.11 and reinstalling 1.9.11.
Then I tried to uninstall the driver in Control Panel. I got this message:
which means “This action is only valid for products, that are installed at the moment”

So the pc recognizes the driver as being not present, but still I can see it in Control Panel, and cannot uninstall it.

And now I tried to install 1.9.5 just to see what happened. It installed ok, so I had two YSUSB drivers visible in Control Panel. Tried to remove 1.9.11 - no success, removed 1.9.5 with success.

Problem appearently solved: I ended up with installing 1.10 disregarding the instructions to unstall the old driver first. That seems to have done the trick, except I do not dare to uninstall the driver now, just to check whether it can be done. But by next driver-update I will try to uninstall - otherwise install the new anyway.

Thank’s for help

has anyone ever used this software without a problem of it and it just working as paid for and expected or always issues? I am so thinking of settling on Logic X that works. just works. seems to me you need a cubase and yamaha team of experts on yourside just to get it working day one. I have asked for help but got sketchy help. starting to lose faith. I want to love this cubase software but I might need a computer science programmer degree just to fix what should be working day one.I really needed the product to work and function great. anyone else had a nice cubase mac experience? I have had nothing but broken software. I wish I could get cubase direct experts to help me I wanted to buy the 9.5 pro version but I am losing confidence fast.

Allright - here we go again. Why the [excuse my language] can’t I install these drivers?
Coming from 1.10.0 I can’t install 1.10.3. Tried 1.10.4 too - no luck. Got the same message, as in my original post.
Back to 1.9.11 with success. Thought I’d then be able to install 1.10.3/4 as described above. No luck. Now I’m stuck with 1.9.11 - can’t uninstall it - can’t install newer.
Please help, someone. This is driving me - well, you know.

Now I’m trying to find the driver and delete it manually.

Here’s what a search comes up with:

Any suggestion on which files a can delete?

So I’ve deleted everything that has the string “ysusb” in it from folders and from reg. database. Still Windows doesn’t install the driver, because it’s allready installed. No, it’s not - it’s been totally erased from the computer.
Do I really have to reinstall my entire system? Anyone else having the problem?

1 Like

Solution: method to uninstall when original msi file cannot be found:

1 Like

Hi Steve and thanks, but eh… I suppose you’re refering to his link:

The installer is looking for that file in order to uninstall the old driver. I had this problem and used this Microsoft utility to get rid of the old install. > … or-removed

That a temp installer file must remain on a users computer over a period of years in order for an update to work is the rudest, user-unfriendliest, out-dated, and ridiculous method around. So stupid. So annoying. So Windows 3.1

It leads me to a Microsoft site, where I can buy a lot of Microsoft crap. No support or guide or anything.

It leads to a program to download, on a page called “Fix problems that block programs from being installed or removed”

Hi Steve.
No, it still leads to a marketing/merchandise-site, at least from Denmark it does (the site shows up in danish).
But anyway - I found the “fix problems …”-site and it worked! What CCleaner, IObit Uninstaller and Wise Program Uninstaller couldn’t do Windows could.
I installed 1.10.3 though - since I don’t dare touching 1.10.4 now.
So thank you, Steve. your advice led me to the solution.

Now I’m really nervous about a future 1.10.5 - should I uninstall the older driver og should I just install the new without uninstalling?

Glad it helped. I guess MS rewrites (and by writes, I mean breaks :wink: ) the url when it tries to forward you to the local language version of the web page.

Removing the localization string fixes it.



Correct universally