Can't whitelist 2caudio Breeze2

I’ve added Altiverb 7 and Breeze2 to the whitelist in the play preferences. Altiverb shows up but not Breeze2. I’d be grateful for any help to get this working. I’ve created a dianostic report which may help. I’m using Windows 10 and Dorico 3 Pro.

Dorico (135 KB)

It does appear that the audio engine hasn’t picked up breeze from your whitelist. Try opening %APPDATA%\Steinberg in an explorer window.
Rename the VSTAudioEngine3_64 directory (eg VSTAudioEngine3_64.saved) and run Dorico again, then quit. Now copy the vst2whitelist.txt from the saved directory and start Dorico again. That should hopefully cause the engine to pick up changes to the whitelist file.

No dice unfortunately. It seems to be just the 2C audio plugins. I tried adding effects one at a time to the whitelist in the preferences, quitting then restarting Dorico, so the whitelist ended up as -

Altiverb 7
Auburn Sounds Panagement-64

All fine except Breeze and Precedence.

Can you create another diagnostic report and upload it?

Thanks for looking, Paul. Here is the report including the other plugins mentioned above.
Dorico (146 KB)

I’m very sorry to tell you, but this turns out to be a bug in our program.
I’ve just tried this myself and whitelist entries that start with a number simply get stripped from the list.
It has to do with legacy handling; whitelisting was done differently in version 1.

Until we come out with a bug fix version, a workaround could be that you make a copy of 2C-Breeze2.dll and 2C-Precedence.dll and rename them to e.g. just Breeze2.dll and Precedence.dll and amend the whitelist accordingly. By that the plug-ins might load. On the other hand, this may cause some headache when you save projects containing those plugs and then open them later when only the original plug-ins are around. So do at your own risk or wait for a bug fix version.

We apologize for the inconvenience.

I’m sure I can manage using another reverb for the moment. Thanks for your help in finding the problem.

Has anybody got Altiverb 7 to show up in the mixer on a Mac with D3.1? It seems to be working on a PC…I posted about this in September 2019 and Daniel replied: ‘Altiverb uses Pace Anti-Piracy protection, and that messes with the code signature in the plug-in, which prevents it from loading in Dorico 3’
Is this still the case? I presume that the PC version of Altiverb also uses PACE, but Sturmgoat seems to have it showing up. I had it available in Dorico 2.2.2, but ever since D3 I cannot get it to show up even though my whitelist is the same.

Sure, the PC version uses also PACE, but the issue is Apple’s tightened system integrity and code signature checks. Therefore PACE needed to bring out an update for their protection software on Mac to fulfill Apple’s new requirements, and the plug-in manufacturers need to link against that new PACE software. So please check if for Altiverb an updated version is available.

Hello Ulf, Thank you for your reply. I have just checked and I have the latest version of Altiverb 7 for Mac. I checked Cubase 10 and Altiverb shows up in the mixer. I don’t quite understand why it works in Cubase, Logic, Sibelius, but not in Dorico. I believe that my vst2whitelist.txt file is good…this is why I was wondering if other Mac users have it working or not. I’m on Mac OS Mojave 10.14.6.

Could you please post a diagnostics report? Thanks

Dorico (1.66 MB)
Here it is:Dorico

Hm, Altiverb got put on the blacklist in your case. That means the vstscanner found an issue with it.
I’d like you to run the vstscanner manually and see what the output is.
Please open a Terminal window (/Applications/Utilities/ and type/copy following command:

/Applications/Dorico\ -p /Library/Audio/Plug-Ins/VST/Audio Ease/Altiverb\ 7.vst

Please copy the output and paste here.

Hello Ulf,
Is there a typo in your command? I get:

[Command not found: /Applications/Dorico]

[Could not create a new process and open a pseudo-tty.]

Thank you for your time!

I thought I should also add that in my Application folder the Dorico app is named: Dorico 3.1 …I still have all the older versions in the Applications folder and they are all named by their version number too.

According to your diagnostics report, your path to Dorico 3.1 is /Applications/Dorico\
therefore I wonder that it can’t find that path. There was a typo in the path to Altiverb, but the parsing did not even get to there and bailed out already on the Dorico path.
Please try again with this command:

/Applications/Dorico\ -p /Library/Audio/Plug-Ins/VST/Audio\ Ease/Altiverb\ 7.vst

I think this is correct.
If it still does not work, go the long way. First do

cd …

several times until you are in the root directory, then

cd Applications
cd Dorico\
cd Contents

and so on, until you are in the Resources directory, then issue the command

./vst2xscanner -p /Library/Audio/Plug-Ins/VST/Audio\ Ease/Altiverb\ 7.vst

Does that work?

Dear Ulf,
I tried ‘Running it inside a shell’ whatever that means, and got this:

Last login: Wed Jan 22 09:13:33 on ttys000
/Applications/Dorico\ -p /Library/Audio/Plug-Ins/VST/Audio\ Ease/Altiverb\ 7.vst ; exit;
Andrews-Mac-mini-2:~ agmusic1$ /Applications/Dorico\ -p /Library/Audio/Plug-Ins/VST/Audio\ Ease/Altiverb\ 7.vst ; exit;
/Library/Audio/Plug-Ins/VST/Audio Ease/Altiverb 7.vst/Contents/Resources/PluginInfo.plist
/Library/Audio/Plug-Ins/VST/Audio Ease/Altiverb 7.vst/Contents/Resources/129.parms
/Library/Audio/Plug-Ins/VST/Audio Ease/Altiverb 7.vst/Contents/Resources/HashConversion.xml
/Library/Audio/Plug-Ins/VST/Audio Ease/Altiverb 7.vst/Contents/Resources/129.parms
/Library/Audio/Plug-Ins/VST/Audio Ease/Altiverb 7.vst/Contents/Resources/vst_host_info.plist

<?xml version="1.0" encoding="UTF-8"?>

/Library/Audio/Plug-Ins/VST/Audio Ease/Altiverb 7.vstFx|Reverb56535441567235616C7469766572622056534541567235616C74697665726220Altiverb 7Audio EaseVST
Saving session…
…copying shared history…
…saving history…truncating history files…

[Process completed]

Okay, cool, there is a bit of XML in the output that I was looking for. So it looks like the vstscanner is fine with Altiverb, though I still wonder why it ends up on the blacklist.

Please try following: Stop Dorico, then delete the file /Users/agmusic1/Library/Preferences/VSTAudioEngine3/Vst2xPlugin\ Blacklist\ VSTAudioEngine3.xml and start Dorico again. Does Altiverb still end up on the blacklist? In that case please post another diagnostics report. Thanks

Dear Ulf,
That worked! Thank you! The newly created ‘Vst2xPlugin Blacklist VSTAudioEngine3.xml file’ no longer has any entries in it. Deleting it was the answer.

Just as an aside - The instructions about ‘Whitelisting VST Instruments’ refers to the VSTAudioEngine2 folder in Preferences. In this folder there is no ‘Blacklist’ xml file…If I had looked in the VSTAudioEngine3 folder I might have seen this ‘Blacklist’ xml file and tried deleting it myself. Just mentioning this incase the instructions need changing? Not sure whether they do or not…I actually have my vst2whitelist.xml file in both folders…VSTAudioEngine2 & VSTAudioEngine3.

In any case, it is working for me now, so thank you very much for your help - Greatly appreciated!

Good to hear that it works again. And yes, we will update the instructions for whitelisting, thanks for pointing out.