Casting off/note spacing issue

Hello Dorico forum!

Since I’ve updated to Dorico 3.5.10, I’ve been having bizarre issues with casting off. My note spacing settings are set to what I believe is pretty usual, but dorico sometimes refuses to automatically break the system when there is clearly too much content to follow those spacing settings. I can obviously fix this by manually inserting breaks in engrave mode, but I know the program is supposed to do this automatically, at least to some extent. I don’t remember ever running into this issue before the last update, but I haven’t worked on that many projects with Dorico. Is there just a setting I’m missing here?

An excerpt of the project I’m currently working on is attached as an example.

Any help would be greatly appreciated!
Casting off issue (1.58 MB)

You have casting off set to a fixed value, 4 bars per system.

Layout Options–Staves and Systems–Casting Off.

Ahh, great… I’m not sure how I missed that, or why that setting was on for that matter - anyway, thank you!