Catalina for Mac and Cubase

Is Cubase compatible with Catalina/Mac ?
If no … any news about it ?

https://www.steinberg.net/en/newsandevents/news/newsdetail/article/steinberg-products-incompatible-with-macos-catalina-5225.html

Applications will need to be notarized and implement hardened runtime, these are quite big changes. We’re getting our applications ready, but other developers might need more time.
Apple postponed these prerequisites to January 2020 to allow developers to catch up https://developer.apple.com/news/?id=09032019a

It’s not just about the host program, but plugins and drivers as well.
https://www.pro-tools-expert.com/production-expert-1/2019/9/18/brands-are-already-issuing-warnings-about-not-upgrading-to-macos-catalina
https://www.sweetwater.com/sweetcare/articles/macos-10-15-catalina-compatibility-list/

In short, please wait, the changes might be more than one expects.

Seems like there are lot of obstacles for sound cards. RME are only ready with their USB stuff and apple seems thinking that you dont need anything else that USB for audio and the USB drivers should be userspace drivers. Expect low-latency issues for some time with Catalina. Mojave was a bumpy road, this will be a more problematic trip. And the worst thing is that the new Mac PRO will be Catalina and no lowlatency audio…

I’ve got Cubase 10.40 running on Catalina with a RME Fireface sound card (latest drivers). No issues till this moment, all VSTs are working as far as I can see. The only thing I had to do is download and install the latest 64 bit E-Licenser (6.11.7.1254) from https://www.steinberg.net/en/company/technologies/elicenser.html

An in-place update will most likely work, for the time being only 32-bit applications will be excluded: the problem will surface if you need to re-install a plugin, or any software for that matter, that does not yet come with a notarized installer once Apple enables the prerequisite in January 2020.

Hardened Runtime is also not enabled yet - once it is, one might find part of the plug-ins blacklisted with no possibility to reactivate them.

(eLicenser 6.11.7.1254 is a legacy version for older MacOS, not rated compatible with Catalina. 6.11.8.9256 is the current version)

Also had Cubase 10.40 running on my MBP 13" 2017 since yesterday running some pretty large mix sessions. No issues with Cubase at all *knock on wood. I did have to update all of my Plugin Alliance plugins, but that was super easy and took all of 3 minutes to download & install.

Sure it works - just be aware that starting in January plugins built against specific SDKs might (and most likely will) stop working.
It is not a generic warning or a guess, it has been tested * - I’d wait for the green light from all devs I rely on.

  • I should specify -partly- tested: it’s a lot of plugins and software out there

What about the following FRESH-install situation:

–fresh install Catalina
–fresh install latest e-Licenser (downloaded separately and installed in advance)
–fresh install latest Steinberg Download Assistant (downloaded separately and installed in advance)
–fresh install latest Cubase 10 Pro
–NOT installing any 3rd party plugins
(all 64-bit)

Is there evidence of “de facto” fresh-install compatibility at this stage? (Not asking re: “official” compatibility here.)

If yes, are there any hidden downsides to performing the above which might emerge later / upon the next Steinberg update round?

Thank you.

Cubase 10 gets installed and works here, but there are no final results yet. I got a dozen plugins not allowed by the OS.
The next Steinberg update round should only improve the compatibility with the new OS, but it’s hard to foresee what may happen with OS updates, driver updates, plugin updates and so forth. SDA works, but will display a warning.
I didn’t see anything shocking so far, but my environment is not working 100% - I would surely not update a mission critical DAW at this point in time and I can’t exclude that something might get worse once the prerequisites are actually switched on.

*cough https://www.meldaproduction.com/text-tutorials/switching-from-osx-to-windows?fbclid=IwAR0ytBKIDYyd-T5tfRfQv6P89novNHuxPHDqOR_J55NgoN2SX8ZOpPgiKr0

NEVER!!!

I guess, the current version of eLicenser not compatible with Catalina.
I can use Halion 6 and Halion Sonic 3 on MacOS Catalina with Logic Pro X (AU) and PreSonus Studio One 4.5 (AU and VST). But it’s necessary to start eLicenser app. During instrument loading the eLicenser app “flashes”. You have to keep the eLicenser app running to use Halion 6.
If I try to use the Halion without starting eLicenser app, the error message appears: “Synsopos not loaded…”.

I guess, Steinberg should fix the eLicenser app.

(The first beta of MacOS Catalina released in june 2019. Four months ago…)

Regards

Here’s my experience with Cubase Elements 10.0.40 and Catalina (10.15.1) so far.

On a superficial analysis, most of my VSTs/plugins seem to work properly. I can use my U-Phoria UMC2002HD, iLok, Waves, Slate Digital, Kontact, iZotope and PositiveGrid easily. I have a small issue with FabFilter, which I solved by disabling Gatekeeper.


The biggest pain in the a** is that Cubase keeps randomly and constantly crashing. I don’t know what triggering it: it happens sometimes when I open a project, or when I click on ‘rec’ button on a track, or simply when I switch between tracks. And sometimes it goes on for hours, on the same project that previously crashed at least 20 times.

P.S.
I know there’s the 10.0.50 update around, but it’s only for Cubase Pro. Nothing for Elements yet? Any news?

So I’ve got Cubase working on my machine with Catalina, and what I’ve noticed is that the DAW mostly works except for when anything uses the surround panner (based on the crash logs).

The two events will reliably crash Cubase:

  1. Enabling Control Room.
  2. Adding a surround track.

In both cases the crash report mentions the surround panner as the reason for the crash.

Would be very curious to know if anyone else is experiencing the same problem.

I dunno if anyone else is having this problem but…

Whenever Cubase 10 tries to load the DAW for the UR22mkII (I have the latest update) the sound output suddenly stops working. I’ve tried reinstalling, unplugging, replugging, everything. Weird thing is that as soon as I close cubase a second Audio Device appears in the ‘Audio Midi Setup’ and all other sound outputs from my computer suddenly work.

Should I just uninstall Catalina or what.

Cubase 10 working for me now with Catalina 10.15.1 using Apollo interface; first day of use, seems pretty solid. Of limited use at the moment until Halion and Groove Agent also work…

Steve.

Absolutely not working over here!!
Cubase Element 8 crashes every time. C’ant even open a project.

I have installed catalina fresh, 10.5 fresh and unfortunately 10.5 freezes as soon as there is a waveform on the screen. It works fine if I just create an instrument channel and load up kontakt or something. But if there is something on the screen (like a few channels with even empty regions) and try to move around, freezez to death.

Snicker! :laughing: