Cautionary accidentals on immediate repetitions (Cross-relations)

I have cautionary accidentals set not to show on immediate repetitions, but the cross-relations in this example are forcing them:

Is there any global setting to get the cautionary accidentals to not show after the first chord here? I have “Show no further” for Accidentals that have already been stated in the bar checked, but I guess the cross-relations are overriding this. I also have “Do not restate” for Accidentals on repetitions of the same note, but again the cross-relations are forcing them. I’d really like to not have to hide all these manually, but I do want cautionaries in other places, so if there’s a global setting that would work for a situation like this, please let me know. Thanks!

This reminds me of https://www.steinberg.net/forums/viewtopic.php?f=246&t=168656&p=901594&hilit=accidentals#p901594…

Hmm, I don’t want “Modernist” though as this is a relatively long piece and I would like to keep the cautionary rules as is for all the other non-chordal instruments. (It’s for a small chamber ensemble)

I guess what I’d like is a setting to not show cautionary accidentals that result from cross-relations on immediate repetitions while retaining other normal cautionary rules. I guess this setting doesn’t exist, so I’d like to submit it as a feature request. In the meantime I guess I’ll just hide these manually.

It was not explicit, but my message meant : “you’re not alone, and there’s some room for adding your voice to the precedent request…”, although Modernist could have been an option :wink:

:laughing: Sorry, I was in work mode and just thought you were pointing me to a possible solution.

I’d guess they are being triggered by the split diads in opposite octaves. Assuming the lower stave is bass clef, then you have a and a# in the same chord. The a natural in the bottom octave is likely causing the cautionary # in the upper octave in the next chord, etc. My guess is this all daisy chained out of control.

That’s what Fred said in his original post.

You’re right. I read it as meaning within the same chord, not affecting the following chords, but now I see what he meant. Ah well… Hopefully there will be an answer to this from brighter minds than mine.

Yeah, this is obviously what is causing them. For this piece, the pianist is the composer. He will be playing the piece at its premiere, doesn’t have these repeated accidentals on his manuscript, and I assume does not want them. Contractually the parts need to ship out tomorrow (already sent him parts via PDF for approval), so I was just wondering if there was a better way to handle this. I’ve manually removed the accidentals so it’s no big deal, but it would be great if there was a setting to avoid this in the future.

For now the simplest method seems to be to choose the chords with unwanted accidentals (use the Edit > Filter to select all flats or all sharps if easier) and use the properties panel to hide accidentals in bulk. Hope that works for you (if you haven’t already used that method).

Good tip! I was just using arrow-key to next note and then a shortcut to hide the accidental, but your way is faster.

You could also use the cursor to select a batch en masse (drag a bounding box) or select the beams/bars and hide all accidentals. At least it gets you multiple selections at a time.