Cautionary / courtesy enharmonic change

Hello everyone

Could someone please help me with adding a warning to a score that the note following is the enharmonic equivalent of the note just played. Here is a picture - it is the little stemless note in brackets that I would like to add.

I tried searching the manual and forum for cautionary / courtesy enharmonic but couldn’t find anything. Apologies if I have missed something.

There’s no built-in feature, but it’s easy enough to use a grace note; hide the stem, and add the bracket. (You can turn off Playback for the note, too.)

1 Like

By sheer coincidence, I had the same question only a few minutes after FergusB, so I followed the workaround, but - under the circumstances that I want the cautionary before the next note rather than after the previous one - a lyric extender line appeared in the previous bar:
Screenshot 03-11-2022 12.22.04
I can hide it using Engrave mode (though it still shows in Write), but why is it there in the first place? It’s as if the grace note is being treated as if tied to the B natural, and is still there if I select ‘Grace note before barline’ in Engrave mode:
Screenshot 03-11-2022 12.32.26

Grace notes are ‘notes’ for the purposes of Lyrics, so yes, you’ll need to stop the extension line, either by entering the syllable and pressing Escape instead of moving on; or by editing it after the fact in Engrave mode.

Adding a hard space as a lyric for the grace note itself might be another option.

1 Like

@benwiggy : Many thanks. You provided me with enough information, so that I could achieve what I wanted, but still had to look up how to hide a stem, and turn off playback. For me, that is so much better than providing step-by-step instructions to follow blindly. It helps me learn more of the app.

A thought. If you put the grace in a different voice, it shouldn’t affect the lyrics?

To change one thing: look in the Properties. To change everything, look in the Options.

There. You’ve learnt Dorico.


It worked, Janus! That certainly comes in the ‘I’d never have thought of that’ category. Thanks!

Thanks again @benwiggy

@Janus, in my project, I did put the grace note in a different voice. I found that it wasn’t possible to remove the rests following the grace note (using the Edit> Remove Rests menu item). I shrunk it to 1% which has the same effect.
Is this because a grace note has to be attached to something - either a rest or a note?

That’s interesting. No rests are created if you enter the grace in a new voice. ie not used before.

1 Like

@Janus. Thanks again. It must be that a new voice is needed. I was using a different voice, unused in the bar, but used elsewhere in the flow.

@benwiggy “to change one thing…etc” perfect! Thank you.

It’s possible that settings in Notation Options > Rests may affect how rests are shown when using voices.