CB 13 convert tracks bug?

In cubase 12 the process to convert a stereo track ( some programs like FL studio and Ableton keep on exporting everything in stereo despite the fact that some tracks are mono) for me was to use the “convert channel. - Multichannel to mono” and then it created a new track with one one side of the “fake” stereo.
Now in Cubase 13 nothing happens, can someone please confirm this ?

The Process:
Create a new project , add a stereo track , import some audio to that track. Select the track , go to project - convert tracks - Multi-channel to mono . There are 3 option:
Source Tracks - choose selected tracks
Options - this here depends , i normally use “mute source track”
Split file format - audio_L ( for example)

The press OK. It should create a new track with only a mono content, for me nothing happens.

Cubase 13.0.20 Build Nov 29 2023

Ok, i just found what is the problem, i clicked the new mono configuration button and like this the track is actually mono so this process doesn´t happen. I clicked the stereo configuration and the process runs like before!
I leave here this if it happens to someone else.

The waveform show stereo content but the channel configuration is mono ( internally)