CC 104 codes for string section sizes

I am orchestrating a big project with around 40 different flows. I use Dorico 3.5 and Noteperformer. I need to define different sizes of the string sections from the default in order to get a realistic balance. Is there a way to set the CC 104 codes globally for all the flows? Following the instructions on this forum, I went to the automation line for each string section, chose 104, and then tried to find the right value with the mouse - this is extremely difficult because the required values (2,3,4,5,6) are small so it’s tricky to find the right point with the mouse. Doing this for one flow is bad enough, but for 40 flows seems like gratuitous torture. Is there an easier way to insert these codes, and one that would hopefully also work globally for all the flows?
Many thanks,
Guy

You might find it easier to define playing techniques for a2, a3, etc, and add the playback techniques to the NotePerformer expression map. You can hide the playing techniques in the score.

You can enlarge the automation lane up to the full screen height if you want. but that is also tedious for 40 flows and several instruments per flow.

Thank you! Editing the expression map is probably beyond my capacities. I’ve tried but there are too many obscure options to choose from… Is there a quick guide as to how to do this? (Is it a ‘base Switch’ I need to add or a “Technique Add-on Switch”? Is it off event or on? Is it C3 C4 or C5? It’s all rather obscure…)

I understand your hesitation with expression maps - sorta like that first dive or dip when you go swimming in cool water maybe, but similarly not bad once you first do it.

Here is what I would do (and did, for a somewhat similar feature in EWQL). First I went to engrave mode and created a few new Playing Techniques. I’ve been naming this kind of purely VST specific technique with a ~ in front of in, just as a convention for my own clarity, searching, and convenience. So you might create techniques named:

~Small NP String Section
~Medium NP String Section
~Large NP String Section.

Or whatever floats your boat. That way, you simply add the appropriate PT to your score/flow whenever you want it - and it means that you can change it whenever you’d like midstream - in different notes or measures if it pleases you.

The expression map part would be easiest as an Addon IMO. Select the Expression Map for NotePerformer, Create a new AddOn Technique with the “puzzle piece looking button”, and choose one of your new Playback Techniques. Now assign CC 104 to that technique with the value you want - and you can enter the value directly so no mouse fiddling required.

On last thing to avoid weirdness when you’ve not specifically assigned a technique to a flow… Go to the “Init” switch for the expression Map (which is a base technique) and add CC 104 with some kind of default that makes sense to you, for times when you haven’t specified one of your new playing techniques in a score.

Choose which group you want to add the techniques to (e.g. Common or Strings).

Click the + icon to create a new technique. Type the name (e.g. a2). Click the “text” box to copy the name there.

Then click the “edit” button to the right of “playback technique.” Click the + icon to create a new technique, call it a2, and click OK. Check you have actually changed the playback technique to a2 after you created the new technique (Yeah, I made that mistake while working the process to write this post!) and click OK.

Repeat for a3, a4, etc.

Go to Play mode and select Play/Expression Maps. Select NotePerformer and click the “duplicate expression map” icon to copy it. Give it a new name you can remember.

You want to create your a2, a3 techniques as “add on” techniques, so they don’t interfere with the existing techniques. Since all these techniques just set CC 104 to different values, you don’t need to bother about how they interact with each other - the last in the score will just override the earlier ones.

Click the "jigsaw piece " icon and, select a2 from the list. Click the CC icon and set the fields to 104 and 2. Click OK.

Repeat for a3, a4, etc. It might be a good idea to create a “tutti” technique to set CC104 back to 0, in case if you ever want to do that.

Finally, click the cog-wheel icon in the VST instruments panel in play mode, and change the expression map from NotePerformer to your new map.



The default value in NotePerformer is 0 which means the full-sized section (not zero players!) so you don’t need to do anything special at the start of a flow.

In fact it is probably better for “init” not to do anything with CC 104, so you don’t get a potential conflict if you add an “a2” technique to the first note for example.

You shouldn’t get a conflict as init will be executed before the first technique, which will then promptly override it unless you know different? The issue I’ve found is that if you are moving around between different flows and don’t have a technique at start of playback, that the instrument is in whatever state you last left it in - the state of whichever flow you happen to have used before it. Particularly painful if we were instead talking about portamento. :wink:

Thank you both for the very clear instructions! I’ve followed them (I believe) to the letter,
defined the techniques, also changed a trial instrument (double bass) to the new expression map (see photo). But when I then add a ‘a2’ as technique in write mode, there is no effect in sound, nor can I see any graphic effect in the automation line when I choose CC104. Where am I likely to have gone wrong?
Thanks again!

Correction - Sorry - I think it is working now…
Thank you for the speedy help!

I don’t know either way, but if Dorico sets all controllers to 0 at the start of a flow, setting them again in init doesn’t add anything.

I haven’t checked what happens in cases like a grace note that plays “before the first note” of a flow.

I thought that had been fixed for playback, though it can affect note entry or playback when you select a note, within a flow, because Dorico doesn’t track all the playback data for every note you select.

Hi!

For some reason, setting the CC 104 to 0 via playing technique doesn’t reset the section sizes for me… Does anyone else have this problem?


It simply returns immidiately to the previous value… You can see a tiny “dent” in the midi CC 104 lane in the screenshot (at the right edge, after the value is set to 12 at the beginning)

I have created playing techniques from a1 to a12, which are all working, and the “a0” should be identical to them, so I have no idea how to fix this…

Can you attach a minimal project that would allow us to reproduce this problem, sakasuri?

Hi! Sure, hope this can help in some way!

One thing, I did modify the original noteperformer expression map and save it with the same name. This way I can import the modified expression map to a new file and it will automatically replace the default noteperformer expression map. This was instead of saving it with different name, that was recomended here.
MIDI CC 104 test file + customized noteperformer expression map.zip (629 KB)

Here are also some screenshots from the settings I have! Maybe I made a mistake somewhere, but I’m just “blind” to it… :slight_smile:



from the NotePerformer manual…: :slight_smile:
“Section-building is used to create authentic sections (8-8-6-6-4) from solo instruments.”
“Section sizes can be overriden (between 2 and 8) using MIDI CC 104”

Interesting, to me the default section felt bigger than a8 and a12 felt bigger than a8. But I need to check this, thanks for the info :slight_smile:

I solved the problem with the a0 not working!

You have to create a mutual exclusion group with all the different section sizes to the noteperformer expression map.

The problem was that you could set the CC 104 value once, but for some reason setting it again would not work (on my computer).

I’ve attached my noteperformer expression map with the section size “techniques” from a0 to a12.
Noteperformer Section Sizes.doricolib.zip (1.4 MB)

I’m having no joy. I attempted to create a “Solo” technique which sets CC 104 to 1. But when I use this technique there is no change.

Also - this only seems to work for one project. When I start a new project, the technique is missing. I tried doing an Export - but the button was greyed out.

Apologies - After fighting with the forum interface for about 10 minutes, for some reason I am only able to attach 3 files. :confused:



Playback Technique Test.dorico.zip (770 KB)

according to the manual, section sizes can be between 2 and 8… (see my post above)
for a solo you might need a solo instrument…

I can manually change CC104 to a value of 1 in the Automation Lane and I hear a solo violin. Then I have to type soli as text. If I need to move that around in the score I have to make the change in the Automation Lane and then make sure to move my text.

I’m trying to find a way to make soli into a PT.