CC messages won't record

Hi,
I spent a whole night trying to figure out what’s wrong with my hardware synth setup (MIDI patch bay, wiring etc.) just to discover that it’s probably a Cubase 7.5 issue.

I tried to record some knob movements of a hw synth, (with CC messages between 71 and 79 assigned to the knobs). Some of them got recorded in Cubase 7.5, some didn’t. The ones which didn’t record showed up in the transport panel’s MIDI monitor, but they didn’t appear in the track’s MIDI input monitor.

I checked the synth in MIDIOX, all knobs transmitted perfectly normal CC messages, then successfully tried to record them in Live, and then opened the same 7.5 project in Cubase 7, and it worked perfectly well in there, too.

The MIDI filter settings in the 7.5 Preferences allow all MIDI messages to be recorded and pass through on all channels.

I’m clueless and can only think this is a 7.5. bug. Any ideas?

-are they already assigned somewhere?
usually when you have them already assigned in quick controls or so, they wont work.
-did you create a generic remote in the device setup?

Hi,

Did you have the track/s Record button enabled when you were recording your CC automation ?

I noticed that if the Track is Not Record Enabled, in addition to Write Automation enabled, then automation is not recorded on the track for HW Synths. So… I would recommend you make sure you have the track Rec. Enabled when you write your CC automation.

On the other hand, when recording CC automation for VST instruments/effects, automation is recorded without having to Record Enable the track, just make sure Write Automation button is enabled.

Hope this helps.

Cheers,
Muziksculp

The problem is in the quick controls section of 7.5
Not at my music rig, but I had the same problem.
Disable the quick controls & you’ll be fine
Neil

Edit - looked up one of my previous replies:

I had a similar problem with my Kenton Control Freak & Korg NanoKontrol.
Had me scratching my head until someone sorted it out.
I thought it was a problem with Nexus, which has hard wired midi cc’s.
But it isn’t

In 7.5, as well as Track Quick Controls, there is also VST Quick Controls.
These use 71, 73-77, 97 & 98.

That is the probable problem.
Oh & check 16-19, 79-82 as well for the track quick controls.

Hope that helps
Neil

Thanks guys, it was the VST Quick Controls.
I’ve been using Cubase since the Atari days and this is probably the most annoying addition of all time. The most basic thing you expect from a sequencer is to record all incoming MIDI events by default, full stop.
Overriding this by enabling an otherwise unwanted feature on “All MIDI inputs” by default without displaying a flashing red full screen alert saying “Hey losers, from now on don’t expect all MIDI events to be recorded!” is just utterly stupid. I wish I could bill this one lost workday on Steinberg.