CC121 Not Comunicating with PC

Hi everyone,

I have just connected my CC121 controller and it is not communicating with my PC. I have installed it into a USB port at the back of my PC but still no joy. I have the latest driver, Tools for CC121. The blue light is flashing and my CC121 says that I do not need to update the firmware. I think the CC121 might be 4 years old. I have never tried it before, there was never enough space for it. My CMC-A1 controller works okay and so does my CMC-PD drum pad and as well as my other CMC series devices. I have reinstalled the Tools for CC121 several times but no joy. Has anyone got any ideas? I used a desktop computer which is only a couple of years old which I built myself although I’m not a tech person. Windows 10. The CPU is a LGA 1150 i7-4790K. Asus MB. Everything else that is connected to the USB ports work okay.

I have just had a thought, if the firmware is up to date how does my CC121 know if it can’t communicate with my PC? Maybe I should try updating the firmware? I can’t see what else to do, really.

I have just restated my PC and I’m getting that sound when you connect a USB device and then that other sound when you disconnect a USB device over and over again. I think it needs a firmware update. Hmm, should I be bold and go ahead or be sensible and wait for a reply? We’re see? Nope, the firmware says 2012. I have just turned my CC121 off and then back on and that sound has stopped.


Make sure, CC121 is not connected to USB 3 port.

Is the CC121 device visible for the system itself? Can you see it in the System Information?

Yes, it’s in a USB3. And it is is system information it says Driver Error. So at least I know it is not the CC121. I will try it in a USB 2, I think there is two at the back.

Thank you.

Thank you Martin, I have sorted it. System information said the driver was not installed, so I downloaded the driver again and I opened the box as before. There was the Set Up icon which I hade been clicking but above that was a folder which said driver. I opened it and saw another Set Up icon which I clicked on it and it loaded the driver. I’m very pleased.