CD drive burner not recognized

I recently installed a new SSD in my Windows 7 Professional 64 bit Lenovo laptop computer, which has been running Wavelab, Wavelab 8.5.30/31 (32 bit and 64 bit) and Wavelab Pro 9.0.35 successfully for several years (I have not un-installed the earlier versions)

Now it is unable to detect the Plextor external CD burner (which is detected as usual in Windows Device Manager). When I try to create/burn a Basic Audio CD from either a file or an Audio Montage, the only “device” shown in the drop down menu is the DDP image…in any of the above named Wavelab products (Wavelab Pro 9 simply says ”No Device”).

How can I get (any of the above !!) Wavelab programs to recognize and utilize my CD drive/burner ?
This is a major problem as I need to create 30 CD’s for paying clients by tomorrow evening !
Steinberg Zero Downtime…is this some sort of Kafka-esque joke ?

I am now staring directly into my own product delivery completion downtime…. as a result of Stenberg non-functionality……


Work a round the problem make a DDP in WL 9 and open
and burn with earlier versions of WL in the mean time…

even check this thread…
maybe it’s related with burning as well

I’m sure someone else have ideas here…

regards S-EH

Thanks for your help S-EH, I tried creating a DDP in WL9 and opening it in WL7, but the same result…No Device recognized.

As I said above. this fault is with all versions of Wavelab from 7 to 9…so an ‘earlier version’ is no help in this case.

I’ve also deleted and reinstalled Gear software, but the verifier/checker cannot find the GearASPI. So back to the problem again…

If it’s an emergency and you can’t get it working with the Gear Driver installers and checkers, or any other way, you could render to wav/cue CD image (with ISRC, UPC, CD text, etc), (“cue Image” is in the render options), then install Exact Audio Copy, open the cue image in EAC and burn from there.

Or buy Hofa burn. Export to DDP in Wavelab and burn in Hofa.

Assuming the burner is recognized by those programs.

The simple HOFA DDP Player app will do the trick for around $10 USD. You wouldn’t even need the fullCD Burn & DDP app. HOFA DDP Player Maker is also a great tool.

I’ve found it’s actually good to have a 3rd party DDP Player (or a few) to help verify/quality control/troubleshoot things.I don’t burn many master CDs anymore but sometimes I’ll use WaveLab, sometimes HOFA DDP Player.

Seems that WaveLab and Windows/PC has a fair amount of issues recognizing CD writers for whatever reason.

So as Bob said, if it’s an emergency, maybe try another app until you can get it sorted.

Thanks Justin didn’t know the $10 Hofa app could burn. That’s probably a better choice than EAC, especially since I just noticed EAC is only free for non-commercial purposes, and I wouldn’t want to advocate it’s use for commercial purposes outside that. Although maybe if you donate you can use it for commercial purposes. Don’t know.

Yep. It’s 11,90 Euros right now (so roughly $13 USD):

It’s pretty rare for me to burn a CD direct from the montage anymore. I’ll usually render to DDP first so I can check the quality of the render for plugin and other errors.

I’m always loading the DDP into DDP Player Maker to send off to clients first but either way, checking all the CD-Text and other things in another app is not a bad practice.

HOFA customer support is also very good.

The cause of a problem is usually related to the last change made, so “Stenberg non-functionality” and “Kafka-esque joke” might be slighty over-zealous conclusions at this point, especially if you haven’t yet raised a support request with Steinberg via your MySteinberg account.

When you installed the SSD, did you re-install Windows? If not, what method did you use to transfer the existing Windows installation?

Can any other application “see” your external CD drive? For example, can you play an audio CD using only Windows Media Player?

Do you remember what drive letter it used to appear under (before you fitted the SSD)? It may be possible that the drive letter assignment has changed and that may affect the ability of the Gear drivers to find it. You could try running Disk Management to check whether it has any drive letter assigned; it can happen that a device will show up in Device Manager but still not be visible in Explorer if it has no drive letter assigned.

Also, have a look through this post, which mentions a number of things to try, even though not all will apply to your laptop.

Thanks for your questions Mr Soundman, they point to a good analysis of the problem. When I installed the SSD, I made a direct copy from the old one to the new, so no re-installation of Windows. I know it’s more desirable to do a fresh install, but the loss of the CD drive was the only casualty from the changeover.

No other application can ‘see’ the external Plextor burner, not even Windows Media Player. It is recognized when I click on Computer and Device Manager as a drive, but fails to start up, whether a commercially made CD or a blank CD-R is inserted.

The drive letter was changed, but I had fortunately kept the former SSD and so re-inserted that, swapping it for the newer one. I was able to reconfigure the Plextor drive letter to match the original SSD designation, but this didn’t change the functionality at all.

The laptop’s inbuilt CD-R drive however was a different story. With the old SSD, it was able to be recognized as a drive by Wavelab and even to burn a CD successfully. However the Plextor remains unusable.

I right clicked on the ‘installed drivers’ when the old SSD was installed, and it showed 4 drivers for the Plextor: a GEAR AspiWDM.sys; a Plextor Pxhlpa64.sys; a B.H.A Corp cdrbsdrv.sys and the Microsoft 6.1.7600.16385 standard driver.

In the newer SSD install only the single Microsoft driver is present. So clearly the Plextor drive is unable to access the GEAR Aspi driver which is apparently vital for its functioning. I suspect this should be my first mode of attack…to restore an ASPI driver so that the drive is recognized. Should I perhaps do a registry clean to ensure that the GEAR driver is first completely uninstalled, and then reinstall it ?

Strange … I have two internal Plextors (but I’m on Windows 10 x64) and there are only two drivers, the standard Microsoft one and the Gear one:

C:\Windows\System32\Drivers\cdrom.sys (Microsoft)
C:\Windows\System32\Drivers\GEARAspiWDM.sys version

I’m wondering if the other drivers are leftovers from other burning software you might have installed over the years?

There is a manual process for removing the Gear drivers here and the latest drivers are here but I think the problems might be related to the various other drivers you have loaded. You might be able to uninstall the other applications but there’s no guarantee each application will clean up its own drivers completely; one thing you might be able to do is go into safe mode and rename the other drivers temporarily to prevent them loading. Not a task for the faint-hearted though, nor is poking about in the registry; if you have a means to make an image backup beforehand, that would be good.

I know this is not what you would like to hear, but a clean install of Windows would probably solve it.

I know this is for an earlier version of Wavelab, but as it’s a Steinberg solution I wonder if it would work as well as GEAR aspi ? Chord Track improvements - Cubase - Steinberg Forums

If I read it correctly it would seem to require re-installation each time a patch is released, although Wavelab updates these days seem to be complete re-installs, rather than incremental update patches ?

If that doesn’t help, and nothing sees a cd in the drive, you could search for “Troubleshoot” in Control Panel, then Find and Fix Problems, Hardware, Configure a Device. That will run a troubleshooter.
Or run the Hardware Troubleshooter on this Microsoft page:

That seems to do the same thing.

If that doesn’t help, there’s this:

Thanks Bob, I’m going to try that registry fix tomorrow (Resolution # 3 in that last Microsoft KB link of yours).
Cheers !

I have had partial success in getting the various versions of Wavelab (6, 7, 8.5 and Pro 9) to at least recognize the existence of my 2 CD writers, and to be able to write to the inbuilt one…but not to the external Plextor (USB 2.0 connected)

The problem of recognizing the external drive (Plextor 708A/UF: USB and Firewire) is common to both installations of Wavelab on 2 separate laptops…a Lenovo T61 Win 7 Professional 32 bit and a Lenovo W500 Win 7 Professional 64bit.
I performed a registry adjustment recommended in an earlier forum contribution by Mljung: Solved: Import Audio CD doesn't work. - WaveLab - Steinberg Forums

The repair is outlined here: Itunes registry settings missing [Solved] and effectively adds the GEARAspi.wdm driver to the UpperFilter.

Having done this for both computers it has achieved the following:
Device Manager recognizes/lists all CD drives, and Device Manager Properties declares for all drives (2 x internal and 1x Plextor external USB) : “This device is working properly”. There are no yellow warning flags for either drive, on both laptops.
It shows the drivers present for each drive (4 drivers for each drive device, in the case of 32 bit Lenovo):
C/Windows/System32/drivers/ASAPI.sys; C/Windows/System32/drivers/cdrbsdrv.sys; C/Windows/System32/drivers cdrom.sys; C/Windows/System32/drivers/GEARAspi.WDM.sys

In the case of the 64 bit Lenovo it shows 2 drivers present for each drive device:
C/Windows/System32/drivers/cdrom.sys; C/Windows/System32/drivers/ GEARAspi.WDM.sys

My Computer shows both drives as being present, with drive letters assigned to each drive.
Wavelab Basic Audio CD across all versions 6 to Pro 9 shows the Ready to Burn dialog as possible for DDP plus each of the 2 CD/DVD drives (internal and Plextor external).
So far so good…

However, when a blank Verbatim inkjet printable CD is inserted into the Plextor it registers as “no disc present”…. when the same blank CD-R is taken out and put into the internal laptop drive of both computers, it is registered as valid and a range of burn speed options (4x to 24x) appears.

When a commercially produced DVD video or Audio CD disc (or a blank disc) is put into the Plextor, it fails to recognize any content…it attempts to read the contents of all inserted discs, and then simply flashes a sequence of 2 amber lights, but the disc fails to spin and the drive ‘hibernates’
So I’m at a crossroads where all 3 drives are recognized, named as being “ready” by Windows, all have several drivers (including GEARAspi) present, all have drive letters associated with them, yet only the internal CD/DVD drives are able to play recorded content or burn a Wavelab Basic Audio CD.

I’m wondering whether I need to delete some of the 2 (or 4) drivers associated with each of the computers…perhaps it is a case that only the GEARAspi drivers are necessary ? However, it might also be possible that the other driver(s) are required for playback of audio or DVD video ?

If someone from this forum with a working CD/DVD writer that successfully burns with (any version of) Wavelab project is able to list the drivers present in their ‘Device Manager: Driver properties’ menu, that might help to determine whether I can safely remove some of these non-necessary drivers ? Can only 1 driver take priority for a particular function, or are multiples (as I have here) required for different tasks ?

I’ll end here for now, but I’m happy to supply additional information if requested, and hopefully this might serve as a helpful ‘solution in progress’ guide for others experiencing the same problem ?

I may have to consider the possibility that the Plextor drive has failed, as the blinking light FAQ on shows the following error for amber flash light blinking twice: “Auto adjustment failed: Cannot read a stamped disc or initialize a CD-R/RW disc because the drive cannot properly configure the focus and track adjustment settings”

Plextor device drivers.jpg
Matshita device drivers.jpg

Your laser is probably going bad on the Plextor.

Great news about everything else.

Have a good 2017.

I did already:
C:\Windows\System32\Drivers\cdrom.sys (Microsoft)
C:\Windows\System32\Drivers\GEARAspiWDM.sys version

The latest result of my experiments to restore my Plextor CD writer was a
complete inability to restore it to working capacity…and when blank discs
(DVD or CD) were placed in the tray the amber flashing lights signified a failure
to auto adjust for focus and tracking of the laser, which seems pretty terminal
(the Plextor was built in April 2004, and has seen a heavy life !)

Replacing it with a Lite-On writer saw an immediate resumption of burning ability,
across all the Wavelab platforms…and additionally the ability to use PlexTools with it !
Oddly, Plextools failed to launch when I attempted to start it with the Plextor burner

DVD/CD drives seem to be a disposable item nowadays, with a diminishing MTBF (Mean Time Between Failures)
so in my case replacement was the best option.

I’d like to thank all who contributed to this issue with advice and guidance, and hopefully
this thread will remain as a source of information for those who struggle with it in future.

Finally, for those who remain loyal to the Plextor brand, there is now a standalone utility which
provides the ability to flash to updated firmware (called ‘pxfw’) contained within a generally helpful
tool called QPxTool :QPxTool - check the quality
Apparently it will give you data like how many discs in total your CD drive has burned so far, as well
as total read and write hours ! It could be worth a further general Google search to see how valuable and reliable this
tool might be (or otherwise) ?

Today i had 2 cd drives dissapear from wavlab (1 internal, 1 USB), and all other cd burning software. They were still listed in device manager but wth yellow marks.

I followed the Microsoft KB Your CD or DVD drive is not recognized by Windows or other programs - Microsoft Support

It was the method 5, registry fix that got them both working again, but had to do a reinstall of the latest WL 9.1 update to get wavelab to see them again.

Today I found out that my CD burner (plextor) is also not recognized in WL9.1 anymore. It’s working in all other software, it’s just wavelab not seeing it (both import audio CD and buring a CD functionallity)
I think it’s strange that just wavelab has this problem, and i’m sure that it worked before I installed 9.1. I hardly use my burner, but I do have some customers that still want a CD every now and then. Would be nice if it was working with having to reinstall wavelab :slight_smile:

I think this could be the same problem as described in this thread