Cd drive not seen on Mac

I can´t get my external Azuz Zendrive U9M USB cd burner to be recognized in WL10.

In the Import Audio CD windon it says “No device”.

Did a search and saw many post about this for Windows machines, but nothing for Mac.

How do I get WL to see my CD burner? I know the drive actually works, because I can see the inserted CD in the finder and in iTunes. Just not in WL :confused:

I´m on High Sierra with WL10.

Thanks

George

Check for OSX permissions I guess. You need to allow access to the CD drive.

Ok. I´m not sure how I do that though.

There are no drivers to install for this cd burner for mac. It just works without any drivers. So I can´t access the device (like a hard drive for example) to change permissions.

I’m able to see the CD burner in Sonoris DDP Player and Hofa DDP Player Maker, and can choose to burn a cd with the burner in those applications. So it´s only Wavelab not seeing it. Every other app is. :neutral_face:

Screen Shot 2019-10-20 at 15.33.26.png
Screen Shot 2019-10-20 at 15.40.39.png


Ideas?

I think OSX showed you an access dialog the first time you accessed it from wavelab, and you must have dismissed it. Hence OSX does not give access to this drive from wavelab anymore.
This is why you have to go through the osx application permission procedure. You can find many links on the internet.

I finally managed to reset the permissions on my Home folder via some Terminal command lines I found here:

https://support.apple.com/en-us/HT203538

That worked! Now WL 10 is seeing the cd burner.

Thanks a lot PG :slight_smile:

Oops! Now it stopped working again!

I just imported a track from a cd via the CD Import dialog. It imported the audio file, then I went to import another track. Same thing again. Now the CD dialog does not see the device any more. What the hell is going on?

Worked 5 minutes - imported a cd track successfully - tried going to the Import CD dialog - no device to be seen again.

In between working (briefly) and not working I have not touched any permission settings.

Generally speaking. On Mac, with CD drives, if another program uses the drive, WaveLab usually can’t see it.

I tend to open the CD import menu with no CD in the drive, then insert the CD and WaveLab will capture control of the drive.

I don’t know if it’s related but MacOS seems to work like this and WaveLab might not be perfectly optimized to deal with it.

Thanks Justin!

That was exactly what it was. Seems I need to open the CD Import dialog before I insert a cd. Then it works as it should. If I have a cd inserted in the drive before I open the CD Import dialog it won’t see the drive. Now I see how it works!

Thanks for the help:)

George