Change harmonic note head?

I would like to change the whole note harmonic note head to look like the half note note head. Played around with that a bit but couldn’t do a fix. Really don’t like the look.

If you edit the relevant notehead set, you should be able to remove the notehead used for whole notes and set up the existing minim notehead to be used for longer durations as well as shorter durations.

Or, you could edit the whole note diamond notehead and increase its size to c. 130%.

I deleted the notehead and used the half note diamond note head, then checked longer or shorter durations, then saved as default but it didn’t work.

I may be wrong but I don’t think I have ever seen harmonics written with differently shaped note heads depending on note value.

Can you share your project file, or a cut-down version of it, so I or someone else can check how you’ve set up the notehead set and see how to get the result you want from there?

Here it hopefully is. Harmonics in question are the last several bars of the solo violin.
harmonics ex…dorico (868.0 KB)

Hi Richard, yes it wasn’t playing ball immediately but temporarily removing all harmonics from the project (meaning the diamond noteheads weren’t in use) allowed me to go back in and fiddle with the notehead set.

Here are two options: one still using the different notehead for whole note harmonics but scaled up to 135% so it matches the normal notehead for size a bit better; and another that uses the minim diamond notehead for all durations.

If you open the Edit Notehead Sets dialog in the latter project, you’ll see how I removed the other noteheads from the set and checked both boxes for “durations shorter than” and 'durations longer than" for the minim notehead. I.e. Dorico will use it for notes under a minim in duration, and also notes longer than a minim in duration. Basically: all notes.

harmonics ex._larger_whole_LH.dorico (878.3 KB)

harmonics ex._one_notehead_LH.dorico (878.1 KB)

On a side note –

  • You had two separate playing techniques with a line positioned manually between them, and both techniques had been moved vertically in Engrave mode. In these projects, you’ll see I’ve deleted the line and instead grouped the two playing techniques together; the default transition line for ‘ord.’ playing techniques is a solid line with arrow at the end, but if you wanted/needed to change this, see here.

  • I also increased the minimum gap between playing techniques and the staff project-wide in Engraving Options > Playing Techniques (if you generally want all playing techniques further from the staff, change this setting once and then you don’t have to fiddle about with each instance.)

  • A couple of dynamics you’d moved graphically in Engrave mode, because they were in the middle of tie chains? You can input dynamics anywhere you want, not just at noteheads – after inputting them, you can move or lengthen/shorten them.

  • You’ve got staves for Horns 1-2 and 3-4 manually appearing on one staff – if you’re not already familiar with Dorico’s automatic condensing feature that allows for separate parts, see here.

  • If you haven’t yet updated to 4.0.10, I would recommend doing so.

1 Like

Thanks for taking the time to do this. I still haven’t had much luck. What specific group are the harmonic white diamond notes taken from? I tried to follow your directions but kept ending up with the same results. I also tried removing all the other note heads from the set. No luck.
I also didn’t have any success with this “using the different notehead for whole note harmonics but scaled up to 135%” as I didn’t see any way to change the size. Frustrated.

1 Like

p.s. I’ve had Dorico 4 since it was released and this is an xml score from Sib 7, so not everything, i.e. voice order, translates correctly.

The set used for the type of harmonics you’re using is the White Diamond Noteheads set. If you open up the projects in my earlier comment and go into the Edit Notehead Sets dialog, you’ll see how I’ve edited that notehead set in each project to achieve the different results.

To edit the size of an individual notehead, double-click it in the Edit Notehead Sets dialog to get to the Edit Notehead (singular) dialog. On the Component tab in there, you can set the size using the Scale X/Y values.

Mostly have it but I can’t delete the other note heads in the set as shown in the example you sent.

In your project, in order to remove the other noteheads from the set, I had to temporarily remove all harmonics and close and reopen the project so that none of them were in use.

You could also try importing your flow into whichever project file I sent that you prefer the setup in, and delete the shortened flow already in there. The music should be retained, but any local properties or e.g. local adjustments to staff spacing probably won’t be.

Thanks Lillie, will give that a try.

That did work but for one small problem. The final bar of the sample won’t go away and is just sitting at the top of the score. I removed all overrides from the page, then used the system track to delete the bar and that didn’t work. Then I tried shift + B and -1 and it’s still there. How can I get rid of that?

Is there an item whose duration extends into the last bar, like a gradual dynamic?

Solved it. Turns out the last bar was listed as a separate flow which I just deleted.

Thanks for your help Lillie.