Change new MIDI track default "All MIDI Inputs?"

Had a bummer the other day when I added a new MIDI track, didn’t check the default MIDI Input, which was set to “All MIDI Inputs,” and while using a VSTi outputting MIDI from an audio track … whacked some of my hardware synths out of default and required a factory reset to get note on and note off messages back to working properly.

(A really great little plug-in called MIDI-Shaper based upon the Curve synth from Cable Guys, BTW)

So I looked through the preference settings and the manual to see if I could find a way to change how MIDI tracks open from the default MIDI Input of “All MIDI Inputs” to “Not Connected.”

Didn’t find anything. Does anyone know whether this can be done and, if so, how?

Just to be clear, I’m not talking about the setup in the Devices window for MIDI ports where you can define what will be included in “All MIDI Inputs.”



Hi Como,
Strange, but here it always is All MIDI Inputs
No idea why or where to set this, nothing in preferences

Wish I could change this too.


True, that. I use project templates, but not track templates … as it takes literally 30 seconds or more for Cubase to populate the template search window, another irritant I’ve been unable to solve!

I believe that is due to the search hierarchy that you see in Media Manager, which first goes through all my content before it reaches the Steinberg VST folder.

You’d think an option for setting default track MIDI Input and Output would be easy to implement and desirable.

On to ‘feature request.’


Or you just disable everything in ‘all midi inputs’ in the midi settings, and your ‘all midi inputs’ becomes a ‘not connected’ :slight_smile:
Fine workaround as long as you don’t actually ever want to use all midi inputs.

Ahhh … maybe you didn’t read the beginning of this post? LOL

I actually would be more likely to disable audio: I’m a certified midiot.


The whole situation here is a bit of a problem IMV since when you create a new MIDI track, ie by “right clicking” on a previous track, it then uses a default output (for me this is normally a hardware device), not what I think would be logical, eg the next part of a multi-part VST.

It would be nice if Steinberg could rectify this situation with a bit more of a logical approach, as well as for the default input which should be nothing, ie “not connected” and then you can otherwise specify a default input in Devices (feature request).

Come on, if you have carefully selected what’s in All MIDI Inputs, then that is what you want to be the default

Friend, I think you are missing the point. It is not about what you want included when you select ‘All Midi Inputs,’ it is about ‘All Midi Inputs’ being the default for new tracks without option to modify the default.

I suppose … and I don’t know if you can … if you had nothing selected under ‘All Midi Inputs’ in the Midi Devices dialog, you would have in fact ‘None Connected,’ but it would say ‘All Midi Inputs,’ even though none were selected. Of course then you would lose the advantage of having multiple inputs easily available for the times you wanted that function.


Friend, I think you are missing the point.

Friend, I really think you do not read me well.
I was reacting to those that do not want All MIDI Inputs to be the default.
I was saying - to spell it out completely - that I want All MIDI Inputs to be the default, just because I can define exactly what inputs are included in it. That’s the whole point.
And if you remember my first answer to this post: I have All MIDI Inputs as default.
We’re trying to determine why it does not in your setup…

Jan … maybe it’s a ‘language thing?’ I do have ‘All MIDI Inputs’ as the default. I’m not sure where you read that I don’t? That is what I am complaining about.

I want to be able to retain ‘All MIDI Inputs’ as an optional choice in the drop down midi input menu in the instpector, but I want to be able to change the default from ‘All MIDI Inputs’ to ‘Not Connected’ when I add a new MIDI track. It is not a big deal … but because I had ‘train wreck’ with my hardware synths getting reprogrammed through use of a particular midi plugin, I was initially just asking if I could change the default from ‘All MIDI Inputs’ to ‘Not Connected.’ The answer seems to be that I cannot. So my further observation is simply that I wish I could. My concerns have nothing to do with what I do or do not want included in my ‘All MIDI Inputs.’

The particular MIDI VST is actually an effect that sits in an audio track insert, not a VSTi in the rack. When it is instantiated you then will find it in your MIDI Inputs menu from the inspector to feed your chosen track … but it is also apparently feeding any track set to ‘All MIDI Inputs’ and there is no way to exclude it from the ‘All MIDI Inputs’ choices since it is not a MIDI channel.


Sorry, Como, I must have been sleepy as I seem to have read your initial post just the other way around :blush:

Everyone of us are sometimes in Write-Only mode :laughing:

All is forgiven! :slight_smile:

Get some rest!


You watch the screen for 30 seconds? You can do a lot in that downtime. Clean something, check your keyboard, drumkit, singer, stretch, get a can out the fridge get the gopher to make coffee. Endless. :mrgreen:
You only have to switch on once a day and not every five minutes?
Don’t tell me you have to sleep as well. :mrgreen:

The only way to get “not connected” is to disable your midi inputs in Devices Setup.
As everyone always wants them enabled then you get “All midi inputs”. The rest is set up via your soundcard Control Panel.

Zactly … and I said “literally 30 seconds of more.” Takes all the fun and usefulness out of all the VST templates … and is why I never use anything other than some of the synth presets when there is no other way to access them.

I don’t think this is quite accurate. ‘Not Connected’ is one of the options that is available in the MIDI track inputs menu from the inspector. So you can also do this by selecting the damn thing. And to put another spin on it with regard to literal specificity, I think you’d get this result by deselecting the checkbox used to include a midi port in “All MIDI Devices” without disabling the ports … which is probably what you actually meant to say, even if it didn’t quite come out that way. :smiley:


Oops, I did but it didn’t really stick with me :sunglasses:
Ah well, seems the conclusion is that it’s not possible to change.