Change size of multiple text items in a score

Nothing found by searching the forum (maybe due to my poor english).

I have multiple system texts in a score and want to change the text size (and style) for all of them. Do I have to do it one after the other or is there a quicker way? Selecting all of the items with ‘select more’ works like a charm, but then?

Custom scale via the properties panel.

It might still be a bit of work now that they already exist, depending on what paragraph style they already have (?) but you could create a paragraph style for these text objects with the font size and formatting you want, and apply that paragraph style to them. Then if you change your mind, all you need to do is update the paragraph style.

Ah, sure, forgot, that I can change multiple objects via the properties panel.
So scaling is possible but not changing the style to i.e. bold/italic.

Yes, Lillie, this would be the best way to do it before using them. But how can I apply a paragraph style to multiple objects at once? (They are not appearing in the properties panel)

Paragraph styles would apply to the text not the text box, so you would have to select the text and change the paragraph style in the Text Properties, not the Properties Panel at the bottom of the screen.

So this will not save you time initially, but (as Lillie says) will help if you need to change that style later.

As others have said or implied; you can’t directly.

Paragraph styles are really powerful, but I sometimes find myself wishing I could go back in a project and retroactively apply them, as you said!

One of the problems is that System Text uses the Default Paragraph Style. Once one created a new style, say TextBox,

  • one can click the star to add it as a default style
  • would one be able to apply it by default to all SHIFT+X or ALT+SHIFT+X typing by default? I cannot find an option to assign a default Paragraph Style to a text object, only using the pull-down on each and every text entry.

It doesn’t have to: look at the Write > Create System Text submenu. You can select any of the Paragraph Styles. And of course, you can set or change the key shortcut for any Paragraph Style (saved as your defaults).

I found the Write Menu entry pull-down to open a Text Input Box with my TextBox paragraph style,…

but I have never created a shortcut and have not managed to reassign the SHIFT+X shortcut to a textbox with my desired paragraph style pre-selected by default. I’ll have to peruse the manual some more to figure out how.

Thanks for the tip.

Derrek, you need to save your new paragraph style as default. Once you’ve done that it’ll appear in the Key Commands section of the Preferences dialog.

I did save my Paragraph Style as a default.
It is getting it to stick to a revised SHIFT+X shortcut that is the problem.
In Preferences I choose the shortcut and the new Para Style, and confirmed that I want to update the shortcut from its pre-assigned value. But is does not stick.

I managed to set up a revised SHIFT+X shortcut that will open a text box with my custom TextBox paragraph style; but try as I might, I cannot redefine the ALT+SHIFT+X to open with the TextBox style. It continues to use (or say it is using) the Default style.

Any advice what is going wrong? (326 KB)

The attached project doesn’t contain such a style. Try using it in the project, then saving the project, then uploading that.

Actually, scratch that - I’ve worked it out without your custom style. For some reason Dorico’s not actually removing Alt+Shift+X from the System Text > Default Text shortcut. Remove that manually and you’ll find that your newly defined shortcut works.

Thank you, Leo. Sometimes buttons in the Key Command editor do not look like buttons until after one clicks them. Once I finally discovered how to do what you suggested, the reassigned shortcut did what it was supposed to.

Again, thank you.

Pianoleo, I seem to be missing something. I’ve made a “new” paragraph style called “Boxed Text” base on the Default Text Parent. I clicked and checked the border option. I hit the star to make save it as default. When I go to the key commands it doesn’t show up as a text option. It does, however, show up in the Write Mode/Edit drop down menu. What am I missing? Thanks.

Sorry, I have no idea. I’ve just followed your instructions and it works fine here:

This is a bug in 3.5. You have to make another change and then it will show up. For your paragraph style, change the font size, hit the star, then hit ok. Open up Paragraph Styles, change the font size back to what you originally wanted, hit the star, then hit ok and now it should show up in key commands.

This was fixed in 3.5.10, though. Seeing as Taniyo is talking about setting the Border property, which was added in 3.5.10, there’s no possibility that Taniyo is using 3.5.0.