Change the Length of a MIDI Event

When sketching music ideas, I often create instrument tracks and use the pencil tool to write out ‘x’ of measures. I will double click on the MIDI event that I created, which at the moment has no (zero) notes. Then the MIDI editor /piano scroll window opens - and I ‘old skewl’ draw my notes in. YES - not as easy or fast as a MIDI controller /keyboard… that’s how I do it.

QUITE OFTEN; I realize, later on of course… I didn’t draw out enough bars /measures at the beginning. Now I want to lengthen - NOT MOVE - length the MIDI event. Help I can’t figure it out?

The MIDI event is generally rectangle shapped, and when you put your mouse over bottom left or right corner - a little black square appears, and the mouse turns into a double headed arrow. BUT not matter how I try to “lengthen” the rectangle (the MIDI event), it ALWAYS moves the event and the notes I’ve drawn. I tried pressing the Shift Key, the Cntrl Key, the Alt Key… whilst dragging the bottom left or right corner of the MIDI event - but I get the same nasty behavior.

C’mon Cubase - make it EASY to lengthen MIDI events.

Frustrated in Philly

Doesn’t happen, here : I can freely redimension any MIDI event without moving it, when the double arrow mouse cursor appeard. Actually, the only way to make MIDI event(s) move is when setting the Key Editor with Snap On, the snap type being set as Shuffle and it’s not even the edited event that moves, just adjacent ones.

So, I would suggest to restart Cubase in safe mode, using the Disable program preferences option…

Make sure to select the appropriate mode for the Selection Tool (Normal Sizing):

Furthermore, you can lengthen the part by grabbing its end border in the Key Editor. For this you need to activate the option to show the part border in the editor:

BTW - I don’t want to sound like a teacher but all of us using the same names for the same things helps in communication, so here it goes…



Thank you!!! Thank you!!! Thank You!!! Johnny M Yes, I did NOT have the arrow tool (Whatever the right name is) set to Normal Sizing as you thought. I set it to Normal Sizing and BINGO, I can extent the MIDI event without moving that actual MIDI notes in/on the event.
You have made RECORDING great again!!! just sayin’