Changing accidentals

I have this problem: I have a written score with 3#'s. Now I want the same score written with 5b’s. I can change the key signature, but Dorico does not change the accidentals. So an E notated in the score with 3#'s comes out as an E flat (not as E natural) in the 5b score. Isn’t there a way to do this in stead of adding naturals for every new bar? I also tried to copy/paste from the 3# score into a 5b score, but Dorico still reads the E as an E flat.
I am sure there must be an easy way out, I just haven’t found it…

I guess you could try something like this. Change the key signature.
Select everything and do Write->Transpose with these settings.


Thanks! It worked!