Changing audio output for multiple MIDI tracks issue

I am again rebuilding my template in VE Pro 7 resulting in around 500 tracks in Cubase. This time I’m on the latest version of Cubase 11 and one thing that gets me crazy is STILL not to be able to select multiple MIDI tracks and then assign them to the same audio output. The default key command used in every other situation when routing multiple items in Cubase is Alt/Option+shift, but for some reason it simply doesn’t work in this case which becomes a very time consuming issue.
Either this is a bug or there is a key command that I am unaware of. If the latter, it causes great inconsistency and I’d want to be able to change it to the default Alt/option+shift. Does anyone have a solution?

I solely use VE Pro 7 as a rack instrument in Cubase.

MIDI tracks do not have audio outputs. Are you referring to Instrument tracks?

Thanks for responding

For every MIDI track connected in the Inspector there is an affiliated Audio Output.
No, I am not talking about Instrument tracks. As I mentioned previously, I solely use VE Pro as rack instruments.
Please see the attached picture. I want to be able to choose one of those audio outputs for all the MIDI tracks selected instead of having to do it one by one which takes 10 times longer.

So assigning the same midi output channel for multiple tracks at the same time?

Works for me on Windows 10 and Cubase Pro 11.

First press Alt/Opt + Shift and hold them down, then click on the midi channel selection with your mouse holding the button down, releasing the mouse button on top of the output channel you want to select.

Again, MIDI channels do not have any audio output. When you select a MIDI channel, the dropdown you have your mouse hovering over on the left will show you what Instrument channels you are going to. In your case you are connected to VEP. The returns from VEP are what have audio output, not the MIDI channels (they only send MIDI messages).

I appreciate you trying to help me, but please, I’ve been working with Cubase since ’98 and I’m fully aware of how MIDI channels are supposed to work.
Again, I never claimed that MIDI channels have an audio output. What I said was that for every connected MIDI track in the Inspector there is an affiliated audio output, basically meaning that the MIDI track can be assigned to an Instrument via the Inspector which in this case is VE Pro, which in turn has a number of audio returns depending on how many you need.
Maybe I was unclear in the thread title and in that case I’m sorry. However you’re missing the point. The issue I have is that selecting several MIDI tracks and assigning them to the same Instrument audio output in the Inspector by holding Alt/Option+shift, clicking on “Output:”, hovering over the outputs presented in the list and then clicking on the one I want to assign to does not work (again please see the previous screenshot). Only the top track in my selection gets assigned to the new output while the others remain as they were before. I can only execute this operation if I do it one track at a time which is ridiculously bothersome and a much slower process.

Also, thanks for chiming in paka.
I’m wondering if this is a Mac thing because I’m trying to do exactly what you describe and it’s a no go.

Hi,

I apologize for the confusion and mistake on my part. I don’t use Vienna Ensemble Pro but I tried it out now with another rack instrument that creates multiple outputs and you’re right in that quick linking or copying of the outputs doesn’t seem to work.

I hope my reply didn’t cause you to spend too much time in trying to get it to work.

No worries, you didn’t confuse me at all. :slightly_smiling_face:
However, as it doesn’t work for you either I believe it’s safe to say that this has not been implemented properly by Steinberg. Bug or not, IMO this is a HUGE oversight which definitely has to be corrected in a future update.