Changing default midi input when adding new track

I would like to have the midi input (the one showing in the inspector) to default to “Not Connected” instead of “All MIDI Inputs” when adding a new midi or instrument track. I looked everywhere I could think of and I can’t find it anywhere; with all the bells and whistles in Cubase, I can’t imagine that Steinberg didn’t think of this…

May i ask why you want that feature ?

Although i haven’t tried this, i assume you could make a Track Preset for an empty Midi Track and a empty Instrument Track, both with Midi Input = Not connected, and save these Track Presets.
Then, when you want a new Midi or Instrument Track, just execute the function “Add Track using Track Preset” and choose 1 of those Track presets you made.

I am aware that this is more of a workaround, but this is all i can think off, in terms of some kinf of a solution.

Hope this helps !

Robbie

I don’t know if the track preset would work, I just tried, and it still defaults to All MIDI Inputs.

How about removing all ports from “In All MIDI” in Device Setup>MIDI Port Setup?

Thanks for your reply, I will try your suggestion for track preset as a workaround to see if it will work for me…

Not having this feature is not a show stopper, but a few times while recording a keyboard track on which I forgot to change the input to only my keyboard’s input, and my son passing by decided to fool around on my e-drum and ruin the take! So I would rather have “not connected” and be forced to configure an input before recording.

I might be wrong in my approach, but it’s the way I see it…

Thanks,
Guy

Tried the two suggestions with no luck. Either through making a track preset or disabling in the device setup, the default still remains to All Inputs.

I just opened a support ticket to Steinberg, I’ll see what they have to see about it… But I ain’t expecting much from there!

If your goal is that MIDI tracks have no midi input device by default, then disabling all the ports in the “In All MIDI” column is the way to do it. This way, no ports will be assigned to the track until you select a specific port from the dropdown.

Thanks a lot, this will do the job for me! I tried this option yesterday and I didn’t think it worked as it still showed “all inputs”. But I had more times on hands today so I tried again. As you probably know already, even though it shows all inputs, according that there is none assigned to “In All MIDI” in device setup it as the same effect as having it set to not connected. Works for me !