Changing default staff spacing problem

I have created some very simple Lead Sheets as individual projects, then decided to import (flow import) them all into one project so the project is a book and the flows are individual songs within the book.

I am trying to set a default staff spacing so all songs (flows) have the same spacing. According to the instructions in the online manual ‘Changing the default staff/system spacing’ I press Ctrl-shift L to open Layout Options, select the layouts I want to change which for me is ALL LAYOUTS, click Vertical Spacing in the list then in Ideal Gaps : Intersystem gap change the space value, so I change the value to 8 from 10, press Apply. Result - nothing happens all the system gaps remain as they were before going through this procedure.

What am I missing ?


You might have vertical justification set, so Dorico is spacing the systems out to fill the frame… and in the process, the resultant gaps are wider than the minimum gap value you had set.

Try fiddling with your justification values in Layout Options–Vertical Spacing. If you want Dorico not NOT do this, set the threshold to 100% (which I don’t recommend, as it looks nicer to have the frame evenly filled, in general).

The “ideal gaps” are more like “absolute minimum gaps”, and quite often your spacing will already be above that if pages are vertically justified. More detailed descriptions of the vertical spacing options themselves are available here.

Lillie and Dan thank you for your suggestions.

I de-selected ‘Justify Staves’ but that made no difference. I have read the manual several times on this subject so don’t think I am doing anything wrong. In this project I have five Flows A, B, C, D and E and two Players 1 and 2, Player 1 is attached to flows C and E, Player 2 attached to flows A,B and D. The Layout Options - Vertical Spacing works fine on flows A,B and D but not on flows C and E, it seems as if there is a minimum spacing imbedded in these two flows as if I select an exaggerated spacing of say 15 all 5 flows increase there spacing, but if I reduce the spacing to 7 flows C and E do reduce again but not as much as flows A,B,D - I’m stumped ?

Only thing I can think of is flows C and E may have originally been created in Finale and Imported into Dorico via Import - MusicXML which may have hard coded a minimum spacing - just a guess.

Can you please post the project here so we can take a look? Otherwise it’s just guessing!

Thanks Dan

When I try adding the project file into this post it says ‘Invalid File Extension’ the Project size is 930KB

You need to zip it into a zip file first, then upload that zip file.

Thanks Daniel didn’t realise that :blush:
Pop Classics (923 KB)

Your vertical justification threshold was still set to 60% (i.e., any frame more than 60% full vertically automatically spreads out across the entire height of the frame). Set the first option in the Vertical Justification section of the Vertical Spacing page in Layout Options to e.g. 90%, and you’ll see none of your lead sheets are vertically justified.

You can check how full vertically frames are, if you have Dorico Pro, by switching to Engrave mode, selecting Staff Spacing in the Engrave toolbox on the left, and checking the frame fullness indicators - they show the percentage fullness of each frame.

Many thanks Lillie, that worked.

Dan your suspicions were also correct, I assumed de-selecting the tickbox ‘Justify staves when frame with single system is above this threshold’ would disable this setting, obviously not as I still had the same problem. What does this tickbox disable ?

It disabled the justification of frames with a single system, just as it says, e.g. orchestral scores where a single system may take up most or all of a page.