Changing from Portrait to Landscape give lot of whitespace

I will print parts to A4 Landscape modus (marching band size). I follow the instructions of Daniel in this thread to change the layout-options.

The layout is changed but there is a lot of white space. The last 2 staves are placed on the second page, but there is enough space to place them on the first page also. Changing the space-size won’t effect (it’s smaller, but a lot of white space.

What is wrong?
Schermafbeelding 2016-10-26 om 09.21.55.png

For some reason, Dorico doesn’t think it can fit any more systems on the first page, which it obviously can. I suggest you select the first note of the first bar, and Ctrl+click the last note of the last bar, and use Make Into Frame to squeeze it all onto a single page.

This works (and something interesting learned today :slight_smile:).

There is only one problem that occurs also before do this: I’ve removed one bar (b -1) and now the stave stops before the end. Is there a way to ‘respace’ this?
Schermafbeelding 2016-10-26 om 15.44.28.png

Go to the Note Spacing page of Layout Options and switch off the option to only justify the last stave when it’s more than 75% full, or change the threshold to something lower.

Daniel, it doesn’t work. I don’t know why but I’m in engraver mode and change the layouts (choose the first instrument on the top, change, choose second instrument on top and change, etc).
When I go to write mode some parts are setting back to the original state (2 pages) and some are on 1 page.

Ah, I’m afraid there’s a really bad bug that means that when you use Make Into Frame (or indeed Make Into System, Lock Frame or Lock System), it will work in the layout that you’re looking at, but remove the formatting from the other layouts. I’m really sorry about this bug, which means you basically can’t use these commands in multiple part layouts in a sensible fashion. This one is already fixed for our first post-release update.