Changing the Contrast or Color of *Selected* MIDI Notes

Software / OS:
Cubase 10 Pro for Windows

Issue:
Please see my attachment, inside the yellow oval – selected MIDI notes inside the editor are very difficult to see, because of insufficient contrast.

What I’ve Tried:
I’ve watched two tutorials and read the online documentation about colors. Also, I’ve tried all of the included color schemes.

Question:
How do I change the color or contrast of SELECTED MIDI NOTES?

Thank you!
Dave

MIDI notes don’t really have any color that is actually associated with the note itself. Instead color is used to display some quality about the notes. In your pic it is Velocity, but it could be a number of other things like Channel Number, Track Color, Chord Track, etc. You select these via a drop-down menu on the upper right. That same menu also has an entry for Setup… where you can configure the currently active note coloring scheme.

Normally in Setup every color will display a label describing what each color represents. However with C10 some of those label are missing. This is supposedly already on the fix it list.

Hello, Raino and thank you for replying. I feel that I understand everything you’re saying, but there’s still something I’m missing.

I should add that I recently upgraded from an earlier version and this is the first Pro version I’ve had.

Let’s be sure I’m in the right place and we’re talking about the same thing. When I’m looking at all of my tracks, and I double-click on a MIDI track, then I’m in the MIDI editor, right?

At that point, when I select one or more notes, I expect them to change to a different color, to show that they’re selected (not to indicate velocity or anything else). When this happens, the color is too similar to the background of the MIDI editor and it’s hard on the eyes.

Can I change just that highlighting color? If so, can you describe exactly how to do it? [As I said, I watched 2 tutorial videos and tried all the included color palettes and couldn’t figure it out. In previous versions of Cubase, this wasn’t necessary, because the highlighted color had a higher contrast with the background.]

I hope this explains my situation a little more precisely.

Dave

Ahhh, got it. Not the question I was answering at all.

For me the selected notes are always black with a color frame around the edge that shows the note’s unselected color. See attached.


Not sure why that wouldn’t be the case on your system. Checking Preferences I don’t see anyway to change the color to anything other than black. Sorry can’t really think of anything else to check. Maybe someone else will chime in.

After reexamining the initial image you posted one big difference in our setups is that I have my background set much lighter than you which helps the contrast. I’d suggest using a Custom Color Scheme. Attached is how I have mine set.

THAT’S THE TICKET! I noticed it before I read that reply, but after I opened your screen grab. Lighter background. I’ll bet that’s what changed between the older version and the new one. Thanks so much for hanging on until we found the answer.

None of the settings I’ve tried in the color schemes seem to effect the background color of the key editor. Unless I’m doing something wrong. That may go back to your original comment about some of the color-able areas being missing from the color scheme list (but coming soon).

I called Yamaha support and the person I spoke to said that in Cubase 10 they made the key editor background very dark and as yet there’s no way for the user to change that, but there have been a number of complaints about it, so that could change in the future. If anyone hears that that has been changed, I’d love to see an update here. Thanks, Raino, for you help!

No, you can change it. It is the box labeled “Editor Area Background” on the image I posted above.

But the range of colors you can change the box to is limited by the basic Color Scheme used, even the Custom Color Scheme. So that needs to be adjusted first to even make a lighter background available. I’m not at my DAW but when I am I’ll post a screen grab of how I have that setup.