Chop/Cut events to tempo map

Hi all,

I was wondering if there’s a way to automatically chop/cut audio and midi events in multiple parts in relation to the tempo map.
To be more precise, I may want, for instance, cut an event which Is 10 bars long in 5 separate events of 2 bars each. And I want this cut to follow the bars configuration, including tempo changes.
Here’s the issue. If I select the scissors tool and use the shortcut alt/option+click, Cubase chops the event in multiple parts which are of the exact same size, but this process doesn’t follow tempo/meter changes, so if, for example, I change the meter from 4/4 to 3/4 or I slow down the tempo from 100 to 80 bpm within the range of the event, the slices after the tempo change will have a slight offset in relation to the bars because they will be of the exact same size without caring about tempo map. Is there a way to fix this?To be clear, I just want to do what Cristian Henson does in this video (https://www.youtube.com/watch?v=2nUa8Rkxkk4&t=674s) at 10:26. He has a variable tempo map and the cuts follow it.

I am new here so I apologise if this topic has already been covered.

Thank you.

Hi welcome to the forums.

This is one of the areas in Cubase that causes a great deal of confusion because Cubase uses some similar terms to describe very different things, so folks mistake one for the other.

But here’s a detailed description of what’s happening.
https://www.steinberg.net/forums/viewtopic.php?t=120844

Hi Raino and thank you for answering.

Unfortunately I already tried to switch between linear and musical timebase on both audio and midi tracks. Same result. As expected, when in Musical Timebase, the events on the track adapt to the tempo variations, but the cutting shortcut still chops the event as if it was in linear time base which is weird. I wonder if this Is a bug or Cubase just doesn’t have this function. I’m on Cubase 10 btw.

OK I can’t quite visualize what you are describing. Can you possibly make an animated gif that shows what’s occurring. Make sure that the Events you are working on, & the Track’s Inspector are visible.

Don’t know how to post a gif here. The link below is to a very short video that shows what happens. As you can see, when I slow down the tempo, the chops start to drift from the bar lines in both the audio and midi event.

https://www.dropbox.com/s/94q51auab1jzcf5/Cubase%20Chopping%20Tool.mov?dl=0

Humm, video wouldn’t play for me.

This is what I use to make gifs (but there are a bunch others). Then just attach the *.gif file like a jpg or png to a forum post.
https://www.screentogif.com/

Here it is!hope it’s fine. Thanks
cubase.gif

So it looks like you are using the ALT modifier on the Split Tool to create multiple cuts on the bar lines but then after the tempo changes the cuts are no longer on the bar line (presumably they are where the cut would have occurred without the tempo change). It all goes by pretty quick so I want to confirm I’m seeing this correctly.

All the Audio Events after the tempo change seem to not be set to Musical Mode (no squiggle on the Parts). In the pool are new audio files getting created as you do this or is it only processing existing files.

What happens if:
A) Instead of using ALT to make multiple cuts, you make each cut separately?
B) You turn off the Tempo Track, make your cuts, turn the Tempo Track back on?

No new audio in the pool, the editing is not destructive. Case A works fine because the snap function just does the job. Case B works on Midi, a little bit trickier on audio, especially if the chops are not in musical mode because they end up overlapping (or having gaps between them) when trying to change the tempo. In Case A the chops are of different length secondswise, but the cuts are aligned to the bar lines, which is what I am aiming at. The problem is, if I use the ALT modifier like you said, the events end up being the same size secondswise and the size of each slice will be determined by the distance between the beginning of the event and the point where we cut (es. if tempo is 120 bpm and we cut after 1 bar in 4/4, the slices will be 2 seconds each, regardless of following tempo changes). So actually what I want to do is what you said in case A, but with a shortcut to get multiple events with just 1 click. Usually, for this kind of functions, Cubase has some kind of box to tick in the preferences menu, or a similar but slightly different function in the editing menu, but this time I don’t see any.

I think method B should work. I made a test case to show.

The audio file is a simple midi drum part rendered to audio so it is obvious from the waveform where the beats in the audio occur. It is set to musical mode. Then I enabled the tempo Track and put in a Tempo change. At this point if I Alt+Split it comes out like your’s where it is not on the bar after the Tempo change.

Ctrl+Z to get back to the initial Audio Event.

The attached video picks up here and shows that if the Tempo Track is not activated at the time the cuts are made they will occur on the bar lines and remain there after re-activating the Tempo Track.


If the beats in your audio are moved around when doing this then try a Render in Place on the audio before you start to cut (not sure if this render is better with Tempo Track activated or not - easy to try both ways). I’ve found that if an Audio Event is not following tempo like you expect that rendering first and then working on this new file often gets things back on track.

Actually it works, but doesn’t help that much. I work mostly to picture and unfortunately modifying the tempo map this way or unnecessary render in place are not an option if I want to keep the project tidy and a good workflow without having to double-check the project for errors in events’ overlapping or routing. I checked the user manual and apparently the function I want is just not in Cubase yet. Hope the developers will consider it for future releases.

While I’m not one of them, there are a bunch of folks on the forum do work to picture (Cubase is quite popular for that). Although none seem to have popped into this thread. Perhaps there is a different way to get the results you are looking for even if you can’t do it via your preferred method. Try a new thread where the question is focused on what you are trying to accomplish rather than the mechanics of getting there.

Good luck