Chord Diagrams At Beginning

I can’t for the life of me figure out what is preventing chord diagrams from appearing at the beginning of my score. There appears to be empty space that does not appear if I uncheck the option to show chord diagrams in the Layout options.
Chain of Fools.dorico.zip (650 KB)

Hi,
In the left panel in setup mode right click on the player where you want to see the chord diagrams (voice in your file) and select the instrument/tunning you want to use.

That’s for chord diagrams above the staff. There is an option to have all of the chord diagrams used in the piece appear at the beginning of the score that is independent of the player setting. That’s what I’m trying to have show.

I think you need to use a fretted instrument in order to get the chord diagrams grid.

I’ve been using this file as a template for all of my ukulele scores. This is the first time it hasn’t worked, and I can’t figure out what has changed. Thanks!

Actually i just test it in a new file, and my guess was wrong, it does not matter if the instrument hat a fretboard or not, the chord diagrams grid can be showed in others instruments.
In your file, create a new instrumental layout and the problem is gone, so the problem is layout specific.

Yes, agreed. I can’t quite figure out why the chords used grid doesn’t appear, but I’ll ask my colleague Bill, who worked on this feature, to take a look next week and let me know.

Lay out options/Page setup/Master page
The master page set you created is causing the problem. Select any of the defaults.

Thanks, Daniel.

That’s interesting. I’ve been updating my template document as I go. I modified the original master page to include subtitle text. I wanted a master page that didn’t have subtitle text, so I opened a new document, exported an unmodified master page, and then imported it into this template. I wonder if something is happening in the export/import process.

Just looking a little bit “deeper”.
In the file you’ve uploaded
Engrave mode

  1. Select the music frame
  2. Unlink the frame chain, that creats a layout music frame and an override on the first page.
  3. In the right panel select the first page and remove the override. The problem is gone.

Thank you for this, but I haven’t worked with layout enough to understand what you’re asking me to do. I’m finding this part of Dorico very difficult to understand. I’m reading the documentation, but it is a very new paradigm for me and it hasn’t sunk in yet.

When I tried to follow your steps, I succeeded in making the chord diagram appear, but the title was missing. I will keep reading up on this aspect of layout.

Never mind. I was just trying to understand what is happening there by isolating the problem.
Anyway Daniel already wrote that they’ll look at it.
Take a look at the gif to see what i meant.
Regards

I have a question that relates to the way Chord Symbols At the Beginning are split into lines.

In a score with, say, 10 chord diagrams, the default is to break the line at 8 diagrams for the first line and the remaining 2 fall on the second line. Is there an option to break the line at the point nearest to the median, so that one would end up with 2 lines of 5 chords?

Hi,
Layout options > Chord Symbols and Diagrams > Chord Diagrams. Set the “maximum number of chord diagrams per row” accordingly.

Thank you!