Chord diagrams overlapping staves above

When adding chord diagrams to a Dorico 2 file opened in Dorico 3 the diagrams are overlapping the staves above in the separate parts and full score but not in galley view. I’ve attached a png.

It’s pretty easy to fix with a few adjustments to the Layout options but I thought I’d mention it here as I’m either doing something wrong or it’s a bug.

Other than this, absolutely loving the update.

Best wishes,


Have you specified a fixed number of systems per-frame in Layout Options? Your chord diagrams are a bit larger than we anticipated most users choosing! If you haven’t got fixed casting-off enabled, you might find it helpful to set it to 7 for this particular combination of sizes, which would give each system a bit more breathing room.

No fixed number of systems per frame and I’ve decreased the diagrams size from the default. The score was imported from Sibelius. Could that be the cause of the problem?

No, I don’t think so. You’ve decreased the size of the chord diagrams from their default? What’s the staff size?

Hi Daniel,

Staff size is 7mm (size 3) for the part and 4.8mm (size 7) for the full score. My apologies, I had made the chord diagrams smaller in another score. The appearance in the picture is Dorico’s default settings as below.

Setting the number of systems per frame to 7 fixes the problem so it’s not a big deal but I thought it best to draw your attention to it.


I just created a new score with a few chord diagrams and there is no problem with overlapping and the size of the chord boxes are smaller so it would appear to be a problem with the score imported from Sibelius, which I’ve cut down and attached.

Many thanks,

Cutdown (700 KB)

I had the same problem with a score created in Dorico 2. Turning on Chord Diagrams in Setup gave me this. Staff size is 100 % Rastral size 3.

Would Reset Appearance have any benefits in this situation?
(I admit I am fishing here.)

I’ve looked into this, and it turns out there is a small bug in the way those new engraving options on the Chord Diagrams page are set up when opening a project created in an earlier version of Dorico. The values of ‘Show nut until first fret higher than’ and ‘Scale factor relative to chord symbol’ are transposed: the former should be 2, and the latter should be 1. We’ll fix this problem in the next update, but in the meantime changing ‘Scale factor relative to chord symbol’ to 1.0 will put things right.

Thank you Daniel, it’s much appreciated.