Chord Track Voicing Range Issue

So I’m trying to figure out how to control the voicing on the chord track so that it doesn’t trigger articulation changes on my instrument…

  • I’ve set the values in the chord track inspector to have the lowest root note AND lowest note to C2.

  • I set the highest note in the range to G5.

  • I TURN OFF root notes for good measure.

  • I set the instrument track “Follow Chord Track” to “Voicings”, and set “Voicings” to “from chord track”

Then I create a chord in the chord pads…

It ignores the lowest note settings in the range and triggers root notes lower than C2. :frowning:

Am I missing a setting somewhere? Or is this a bug?