Click and drag in Time Scale (zoom) delay

In Cubase 8.0.5 Pro, I notice a serious delay when I click and drag via time scale in the project window.

Here it’s more like click --> wait --> and drag to zoom

Never seen that in Cubase 6.x.x
Is there a solution for this situation?


Is it actually a delay or a “null zone”? This was introduced in C7, if it is the latter. There is a discussion about it in the C7 forum.

I have this too, this is new in 8, before - all the way back to sx, there was no delay in drag to zoom. (on any of mine computers)

After trying Cubase 8.0.5 for two weeks I’ll go back to version 6.x.x

Hope we get a fix soon,…


This is not new to C8. The change in behaviour started at C7; here’s the thread from the old (Read Only) C7 Feature Request forums:-

And a follow-up thread at C7.5

So, its known about within SB Towers… what will be done and when (or even if…!) is anyone’s guess. All I ask for is an option in preferences, to turn the darn annoying ‘delay’ off… so those who like it can keep it.

I suggest getting in touch, to let them know your wishes on this; change can happen…!

agreed. preferences is good!

First I like to thank you all!
Special thanks for the links by puma0382!

I had no idea it was planned to be sluggish?
It’s like i’m using a computer for the first time.

I’ve upgraded all Cubase versions but never played with version 7.x.x so,made a jump from version 6.x.x to 8.x.x because,… (if you really wanna know I’l write you a book)

This has been bugging me since i updated from 6 to 8! I wish i could just give them a call and say “please have an option to turn this off in preferences!” lol, annoys the hell out of me!

Hopefully we’ll see it in a few updates time…

Lets bump this one, two, …times

+1 It is still somehow sluggish with 8.5.10. I have the feeling it has something to do with the “speed” of the dragging. Compared to Ableton Live or Studio One it is nearly unusable.