Clicking a Note in Write Mode Triggers Staccato (even though notes have "natural" playing technique)

Dear Dorico Community

I’ve noticed that clicking a note while in write mode will trigger a staccato articulation, even though none of the notes have a staccato articulation attached to them. (They show as being “natural” in the key editor, which should trigger e.g. a “long” articulation in the BBC SO expression map, so is not mapped to a staccato articulation in the expression map at all.)

Is this expected behavior?

Screenshot 2022-12-27 at 19.12.26

Screenshot 2022-12-27 at 19.13.58

Is there a way to change this to another default? (i.e. don’t send out a key switch for the staccato articulation, because the notes are shown as “natural”, not “staccato”)

Thanks for your feedback & with kind regards


Could you export a MIDI file of your little test project, zip it up and attach it here?

1 Like

Thank you Daniel, I’ll send the project file to you. All the best

are you talking about playback here or simply auditioning the notes? When simply clicking on the notes in your test project, I can confirm your behaviour which is rather strange. The actual playback is correct, though. I’ll have a little look at existing projects using the BBC SO library as I don’t remember this before.

Hi @dko22, thanks for replying, yes, this is just clicking notes in write mode. Playback is correct.

I’ve experienced this when the VST’s current selected sample is staccato (or whatever). Audition playback will use the staccato, but ‘real’ playback will reset the sample.

1 Like

I’ve checked in a symphony which uses my BBC Core and the behaviour is the same. String instrument notes which do not have a specific playing technique are generally auditioned with staccato, irrespective of length. This applied even if the note length automation is disabled. However, woodwind and brass do not show the same behaviour. I haven’t noticed it with the other libraries I’ve been using recently but will go in and look more carefully.

Just checked with an Orchestral Tools library --here if anything the opposite happens. Staccato articulations are actually auditioned in general with a normal sostenuto patch. It’s not the sort of thing which has ever really bothered me as I have never expected the MIDI chase to be fully operational when just clicking on notes but it would be interesting to know what the expected behaviour is as it does seem rather random.

Actually, to extend this further and to bring up something which has certainly been raised before, even with normal playback, the correct articulation with many libraries often does not kick in straight away. MIDI chase issues are not specific to Dorico but it would be interesting to know why there are often so many issues with correct articulations being immediately picked up on starting playback, Behaviour certainly varies from library to library with some tending to be worse than others.

1 Like

Hi @benwiggy, thank you too for reporting.

Actually it’s interesting: I’ve checked with the BBC SO Core VST player, the active articulation there could be anything, e.g. longs, and when clicking a note in Dorico’s write mode (with no staccato articulation attached to it, just like in the screenshot), then Dorico does in fact send a key switch for staccato to audition the note.

I’m very interested to understand why this is the case and how to change it.

Thanks to both of you for checking/confirming!

Perhaps Dorico simply selects the first option presented by the VST when you audition notes.

What is happening is that Dorico is choosing the Natural switch with the Note Length <= Very Short condition, rather than the Natural switch with no condition. As such, it’s emitting the key switch defined in that switch.


except that, as I said above, if you disable the automation so that there is no longer any active Note Length “very short” entry at all, it still plays staccato with the BBC.

Ah, thanks for clarifying! :ok_hand:

What I don’t understand is that this only happens when clicking the note in write mode, but not when playing back the bar or exporting it (as one would expect, for consistency reasons?)

Would it make sense to make this behavior consistent, across write and play mode? (i.e. either trigger Natural switch with the Note Length <= Very Short condition both in write and play mode, or trigger Natural in both)

(Of course I might miss the subtleties of why the choice for this behavior has been made)

All the best

I think that there a different logic involved in simply auditioning a note so you can hear which note it is, which is basically what Dorico does, and auditioning a note so it sounds exactly like in playback. This would logically also require the note to always sound for the correct length which can, in the case of ties go on for several seconds!. It would be perhaps nice to have this option but I’m not sure how much programming would be involved in that case.