Clicking sound when disabling EQ's

I just upgraded to Cubase 8. When I disable an EQ, a “clicking” sound happens. What’s weird is since installing Cubase 8, this happens in 7.5 too. is there a way to fix this?

A) That is not normal and shouldn’t be happening.

B) It is most likely caused by your specific system configuration. But since you don’t supply that info it is unlikely anybody can offer any real advice. I’d suggest putting your system details in your signature. :wink:

IIRC - and if you’re using the channel strip EQ’s - there’s a setting for “softer” eq transitions.