Clock go forward = plug-ins scan

Cubsse Pro 8.5.20 - Win 10.

The UK clocks change and yet again Cubase feels the need to re-scan all my plug-ins.

This problem has been around for many years now. It must surely be a simple fix. How about it, Steinberg?


what I gather about it is this is due to how Windows handles DTS on NTFS volumes - after a time change, the files will appear as having a different time-stamp, thus forcing a re-scan (like when you rename a dll, a folder, move dlls to different folders, etc.).

In order to avoid it, one can uncheck the ‘Automatically adjust clock for DST’ in the Time Zone Settings and change time manually.


Sorry, but that’s not a ‘fix’. Cubase needs to understand what is happening and take the appropriate action. I don’t want to uncheck automatic DST - I like it just the way it is. The only piece of software that seems to have a problem with it is Cubase. A fix really is needed - not a workaround. This has been going on for years.


I didn’t say this is a fix, but ‘in order to avoid it’, which indeed implies it is a work-around.
We all know this has been going on for years on Windows. Yes, it is annoying when it happens - for us as well, as some users have crashes on start due to plug-ins which were previously initialised but not used, thus sitting there harmless, and this results in an increase of support requests. I’ll bring it up again with development.

Thank you, Fabio.