Cmc-tp doesn't work anymore - Cubase 12, Mac Studio

When I first updated to Cubase 12, I was happy to find that my beloved CMC-TP controller worked as expected. Now, though, it doesn’t show up anywhere, or work at all. I’m now on a mac studio, rather than my old Intel mac, and I’m not sure if I’ve ever tried it on the studio, so maybe that’s the problem. It doesn’t show up in cubase MIDI remote manager, doesn’t appear in mac Audio Midi Setup (I’m not sure if it should). I have had issues with some devices due to the ever-stronger security features, needing to go into the security/privacy panel and allow things, but I don’t see anything there that would help with this. When I do a mac system report (from “about this mac”) the cmc-tp controller does show up, so it is truly plugged in.

Any ideas? Anybody else have cmc devices working with cubase 12 on a mac studio?

Works now! Turns out I needed to add a couple of drivers. If you have the same problem, here they are.

https://o.steinberg.net/en/support/downloads_hardware/downloads_cmc.html