CMC-TP Play and Stop buttons not working anymore

Other then those 2 buttons, everything else works fine. They have seen the most action so I am pretty sure the rubber contacts need to be cleaned. I can’t seem to locate the screws to open it. Are they under the rubber foot pads? Minus the obvious one in the upper left. Any help appreciated. My warrantee is long gone so just need to know how to get it open. Thanks

I need to clean it too - my problem is SHIFT button !

I got into it but I was only able to fix the play button. But if anyone wants to give it a go: Take the rubber pads off to reveal the other 3 screws. It will almost open but not quite and you’ll notice something is still holding it together near the middle. There are 4 hidden plastic clips, 2 on each side near the middle. I took the backside of a thin knife, and while gently pulling the case open a tad, I ran it in between the 2 halves of the case and it released the clips. Of course I did this on the other side and broke one of the plastic clips. After that it’s just one screw that holds everything together. May or may not fix it. Didn’t work on the stop button. I tested the contacts with an ohm meter and everything looks right so I’m not really sure what it could be at this point. Maybe that one rubber pad. Just using play and stop on my QC for the time being.

Thank you Max !
I will try to do something !

I need to get into my Transport Controller to clean up some contacts - if that is what is wrong. Any recommendations on how to clean the contacts. Many years ago I used a silicon spray on contacts - is this still recommended?

Any advice appreciated.


Same issue here. I opened up the unit and tried cleaning etc without result.

Now I know why they were so cheap. Very limited support lifetime and cheap/shoddy build quality.

Since my last post, some buttons had stopped working altogether, specifically the: ‘F3’, ‘Nudge R’ and ‘Event R’ buttons.

So I opened up the unit again and tested the button while connected to my PC and flexing the circuitboard a bit.
I noticed it would give a response now and then. So seeing as it was pretty much useless anyway at that point, I very gently bent the circuitboard just enough until the buttons worked.

So for now, all buttons are working again, but I’m aware this is most likely a temporary fix. Hopefully it will keep me going until I find a decently priced 2nd hand one, or if a decent alternative comes up. So far, the only real alternative still seems to be the Presonus Faderport, but that isn’t USB powered and lacks user assignable buttons. All other midi controllers I’ve come across have either pads, a keyboard section or other additional controls which make the device footprint too big.

Why did Steinberg discontinue this product? It was perfect for my home studio (except for the shoddy build quality that is).

I believe the presonus faderport has also been discontinued for a while now, so make sure it’s supported on your system.

Good call. Strangely enough though it is still widely available through all main retailers here in the Netherlands, unlike the CMC’s, which ran out extremely quick at some point. Not sure what to make of it.

Thanks for your post - even 5 years later, it was very helpful for me in taking apart my CMC-TP !