Collision avoidance

Hi guys, I wonder how to work with collision avoidance when it comes to bar numbers. Dorico generally does a great job with automatic collision avoidance, except it seems to ignore bar numbers. Any ideas? It happens even with ample space left on the page to space things out more…

Screen Shot 2023-02-08 at 11.37.31 AM

This seems to be very tight vertically, which is contributing to the bar numbers ending up colliding with other staves. It might be helpful if you can share the project file, so the full context can be looked at.

It’s partly a matter of preference too, but in order to allow the bar numbers to sit as close to the staff as possible, you may prefer to position them above the staff in this layout, rather than below? Although of course that depends on the overall balance of the layout; this excerpt may not be demonstrative.

1 Like

Hi Lillie, thanks for your response.I tried to upload the project file but it’s bigger than 4mb so it won’t let me. There’s hardly anything in the score, so I’m not sure
how to decrease the file size…

here’s what the full page looks like if that helps:

EGL_6m50v3_MP.pdf (52.7 KB)

Try applying the Silence playback template, from the Play menu.

Right, it’s not vertically justified and the gaps between systems are quite small. You could try increasing the minimum gap between systems (Library > Layout Options > Vertical Spacing).

Got it, I’ll try that. But isn’t the whole point of collision avoidance that it does this for me, that it automaticallyincreases the space beyond the default setting when it’s necessary? Is there not an equivalent of Sibelius’ ‘optimize staff spacing’?

Dorico’s spacing is typically excellent; that’s why I’m interested in seeing the project file itself.

I can’t find that silence function you mentioned.

never mind, just found it, sorry

EGL_6m50v3_MP.dorico (813.6 KB)

I’m not sure of what your preferences are, but I would try a few things out - I just did and they look much more favourable:

  • open Layout Options and in the Bar Numbers section, change the Horizontal Position to “Centered on barline”. Also, Placement to “Show above top of system”.


  • open the Library Manager and reset your Layout Options to Factory and see what you think? NB If you don’t omit important customisations (eg bar number placement, vertical justification, etc) from this reset then you will need to reapply them in Layout Options.

Thank you, Daniel, I appreciate the help!

1 Like

The main issue with your project, Christian, is that the page is insufficiently full for Dorico to perform any vertical justification, so all of the systems end up squished together at the top of the page. I’d suggest you go to the Vertical Spacing page of Layout Options, and change Justify distance between staves and systems when frame is at least n % full to e.g. 40%. That will spread the staves out across the page and make things look a bit better.

You might then find things spread out a bit too much, in which case you could consider either having fewer bars per system (e.g. using fixed casting off on the Staves and Systems page of Layout Options to specify, say, four bars per system) or you could reduce the height of the music frame a bit in Engrave mode so that the systems are still nicely justified, but the music frame ends before the end of the page.

Thank you so much, Daniel, that really helps!