Collision between Natural signs and previous note

When I add flats and sharps Dorico allocates space for the signs automatically to avoid collision with the note before. But it seems not be the case with naturals (see attachment)?
Is there a way to fix this globally?

Did Dorico cast off this system automatically, or did you add a system break?

I don’t believe Dorico would produce this result by default, and you must have either fixed the casting off in Layout Options to four bars per system or by some other means coerced Dorico into forcing more music into the system than actually fits. In situations like this, you can use the note spacing tools in Engrave mode to e.g. close up the gaps after the start repeat barline and work your way along to try and get things to fit, but there really isn’t enough room on this system, so you should probably consider changing the casting off.

Yes, I have forced more into the line than Dorico would do by default, and I’m aware that it can give problems that need manual adjustments. What I find strange is that whenever I add or remove sharps and flats, Dorico adjusts the space and ends up doing a fine job even if space is very tight. But that is not the case with natural signs.
I had hoped that I could make a global adjustment for the naturals, saving me some work.

Well, I found a solution - even if I can’t tell exactly what made the difference. See the new look of the same line in the attachment

Heres is what I did:

  1. I changed the Default Notespacing in Layout Options to smaller values.
  2. Did the same for various settings in Engrave Options.
  3. Set the default note head size to normal instead of default large.

But I still believe I experienced a bug - I think Dorico should handle spaces around accidentals in the same way even when I push the limits.

Why is there so much space between the repeat mark and the first note in each measure? And so little space between the last note in each measure and the repeat mark?

@John Ruggero,
I can’t tell you why- it is Dorico’s spacing, and I have not found anywhere to change that globally. I have tried to use the note spacing tool - but it is really tedious to manually move the notes one by one to use the space better. It is not possible to select more notes and move them as a group, you have to deal with them one by one.

And in didactic works like the one I am working on, it is not a solution let Dorico decide where to place line breaks.

Engraving Options > Spacing gaps > top section. Fiddle with numbers 2 & 3 to reduce the gaps between the repeat mark and the first note in each measure.

@ Pianoleo,

Thank you, that did it - set the values to 1/4 and 1/8.