Collision between two voices

Well, this is unexpected.

Any suggestions?

Looks like you may have the ‘Rhythm dot consolidation’ property set for the up-stem dotted crotchet. Try switching that off.

Am I supposed to be seeing more than the word “Image” as the second paragraph of the opening post of this thread?


That depends on your browser, David. My browser also shows just the word “Image”, but fortunately I have super-secret admin powers so I can find the URL of the image hosted on an external site. Firefox is careful to not show insecure elements when the rest of the page is secure, because it leaves you susceptible to “man in the middle” attacks. At the moment I’m not sure what setting you can change in your browser to make it show images under these circumstances.

That’s very odd! Usually I see either an actual image or a link to a file.

Obviously, two colliding voices are considered a security risk!

When I get desperate I can fire up Chrome, but that itself has implications…


I can see the image OK using Firefox, FWIW.

I wish I knew WIIW, Paul!

You are correct: I discover that I can see the 5/43 clash on my desktop that runs Win7 and Firefox; but not on the laptop that runs Win 10.

This is not the only wierdly descrepant behaviour that I notice between the two operating systems when it comes to Firefox. As far as I have been able to ascertain, the two Firefoxes are configured identically, and yet behave diferently on certain websites…


Obviously, two colliding voices are considered a security risk!

At first I thought this post said “Collusion” between two voices!

I can see the image on Mac Safari.

Sorry for the slow reply. Where do I find this property? (I can’t see it in the bottom panel, where in any case nothing is switched on.)

Edit: Never mind, I found it (Engraving Options > Notes > Rhythm Dots). You’re right that this was set to ‘preferred’. Setting it to anything else (allowed, allowed only for unisons, or disallowed) fixes the problem. I have to admit that I no longer understand what this setting does. The explanation in the dialogue suggests that it only applies when opposing voices have dotted rhythms, which is not the case here. Can anyone enlighten me?

Also, is there a small error in the diagrams for ‘Allowed only for unisons’ and ‘Disallowed’ here? The former diagram seems to show a unison where the dots are not consolidated, and the latter shows one where they are, which seems to be the opposite of what’s intended.

…or else I really don’t understand this at all, which is at least as likely! :slight_smile:

Don’t worry, you’re not alone. Although two of the four pictures in the dialog are indeed the same, the options themselves do something different, though the pictures do not adequately capture what’s really going on.

That option is really pulling double duty: it is both determining whether or not two unison dotted notes of the same duration should show one rhythm dot or two, and it’s also determining how aggressively Dorico should try to reduce the horizontal width of a pair of voices where both voices are dotted, at the expense of possibly showing fewer dots or otherwise introducing question marks over which of the two voices are actually dotted.

We have reworked this option in advance of the new update into two easier to understand options, so this will all (I hope) make more sense in the new update.

Good news! Thanks.

(I still don’t really understand why either of these “double duties” apply to a situation like mine where only one voice is dotted — but I’m sure the reworked version will clarify!)

It does. And the incorrect spacing is fixed. Thanks!