Collision with accidentals

Not sure if this is a bug or just something that hasn’t been implemented yet. I’ve noticed certain accidental combinations don’t avoid each other while others do. It seem to only occur when a double or triple flat is above a different accidental. Attached is a picture of an example.

I can use the accidental column property to fix this manually but wanted to know if this can/will be done automatically.
Accidental Collisions.jpg

This is evidently not quite right. You can avoid the collision by setting the option to use either precise or fixed measurements for accidentals (in the Advanced Options part of the Stacking section of the Accidentals page of Engraving Options) to use fixed measurements, but as the comments there say, this produces more conservative stacking arrangements overall. We do need to look into this specific case at some point in the future.

@ Daniel
Out of curiosity does this kind of collision has to do with the “cutOuts” anchor points of these accidentals?

It shouldn’t do, since both accidentals have reasonable cut-outs defined.