Collisions between staves

Gah. So I’m hitting a problem that occurs in Sibelius that I thought (I am still hoping!) Dorico had nailed:

In setup / layout options I have selected “automatically avoid collisions between adjacent staves and systems”.

I want to use Rastal Size 5 (6mm) in my score, but whenever I select it i get collisions like this:
01.png
So I try inserting a system break, but now I get the same issue somewhere else:
02.png
If I use Rastal Size 4 (6.5mm) everything looks great. But I don’t want to use Size 4.

Any ideas why I’m getting these collisions?

p.s. I know there are work-arounds with system and frame breaks, I’m only curious as to why Dorico doesn’t spot that objects are overlapping onto adjacent systems.

p.p.s. now I’m working with frame and system breaks and the problem is compounding further into the flow:
03.png

I would need to see a bit more of your music to be able to say for sure what might be happening, but I expect the issue is that you have a high density of items above and below the staff, such as ornaments, dynamics, pedal lines, etc., and if so, you should probably increase the various default values for the ideal staff gaps on the Vertical Spacing page of Layout Options.

During the layout process, Dorico has to make an estimate early on about how much music it might be able to fit into the frame. It uses the number of staves in the system, their ideal gaps as defined in Layout Options, plus some heuristics about the items positioned above or below the staff to make a guess as to the likely height of each system. At this stage, it doesn’t know exactly how the music will be cast off, so it can’t be precise. It is also aggressive, i.e. it doesn’t allocate much extra space for things like dynamics, etc., because we don’t want Dorico to space the music out unduly wide.

If your music typically has a lot of extra stuff protruding above and below the staff, then the best approach is to increase the relevant staff-staff gaps in Layout Options, which gives Dorico a hint that it should expect each system to be a little taller.

It’s probably not the case that, unless your music is very uniform in the density of its additional notations etc., you can come up with a single value that will work for every single page unless you choose something pretty loose, but you should still be able to get good results on the vast majority of systems with a bit of tweaking to Layout Options.

Thank you Daniel.

You are absolutely right about item density. I will have a play around and will post some larger samples if I can’t get the result I need.

I too run into regular collision/overlap of staves, or overlapping staves (with no manual adjustments in engraving mode being made). What is curious is that some pages which have exactly the same number of visible staves are rendered correctly, and other pages with identical staves (especially near the end) overlap each other. I know that I can manually override those “automatic” system/frame breaks, but it would seem that Dorico should see the collisions happening. I’ll post an example (or email it to Daniel) if it’s helpful. But it is frustrating, as this seems to happen regularly/randomly.

dwlarson, please read my reply above, which explains why this is happening and provides some suggested remedy. If you find that the suggested remedy doesn’t help, I’d be happy to take a look at your project.

I’ve run into this problem more times than I would like… this last example is not enormous but the like happens again and again
…and I don’t think it is cramped…

I have tried to reproduce this problem, but it’s working fine for me. A sample project of a few bars would help us solve it.