Colors on selected tracks

I have a session where I use Keyscape. This track is colored light blue. When the track is not selected the midi events is colored white and when the is selected the events are colored light blue - the color of the track. That works fine.
But if the track is colored dark red, like my bass track then the midi events get drak red on a black background when the track is selected, and that doesn’t work at all.
Isn’t there a way to make those colors work better?

1 Like

It’s been some time since I adjusted the colours to my liking.
I think I was using:

  1. Preferences → Event Display → Event Opacity
  2. Preferences → Event Display → MIDI → Note Brightness
1 Like

Beautiful! Thanks a lot!

MIDI notes in selected MIDI parts have always the color assigned to the track (part), that cannot be changed elsewhere. The Note Brightness (Preferences>Event Display>MIDI) setting only affects MIDI notes in parts that are not selected.
To achieve decent readability, the colors of the track (part) and the color of the Project Area Background setting (Preferences>User Interface>Color Schemes) should be contrasting, i.e. light/dark or dark/light. The Event Opacity setting (Preferences>Event Display) should be centered or even a bit closer to min. for a sufficient effect.
The combined use of dark and light track (part) colors is questionable, as the colors with a brightness corresponding to the background will always be difficult to recognize (e.g. dark red on black, light blue on white).