Comp Range problem

I know I’m late to the game, but I’m trying to use the comp tool for the first time in Cubase 7.0.7 64-bit. (Windows 7 Home Prem. 64-bit OS w/ 8GB RAM)
I had a look at this video
and it seemed pretty straight forward.
That is until I tried it on my 7 lanes of a vocal that I created.
I’m trying to break each comp section into the phrases of the song.
So for instance, the first phrase starts at
I click on the Comp tool (glad it’s not a middle finger) at the beginning of the phrase and I want to drag the comp tool to the end of the phrase which is roughly at
But instead of ending the comp at that end location, Cubase never allows the length of the comp area to be less than one bar so it always shows the end of the comp area at
This is obviously not good for my song because that area is already into the second phrase of the song. ???
I thought that there might be some quantizing involved that I had setup but my Auto Q is off as is the Interactive and Audio Warp Q.
Does anyone have an idea of a setting I might have turned on for this to occur or what may be causing my problem?
thx in advance.

Could it be a snap thing?

Try hitting the letter J, then dragging your comp range … does it work as intended now?

Sorry, not at DAW to check, but I can report the range I draw isn’t “adjusted” to the nearest bar/beat by Cubase.

Yep, that was it Alexis.
I noticed in the video that the adjustments were not being made on bar/beats as well.
thanks again.
ciao, Dan

You’re welcome, DannyDep!